Can't authorize my new Fuze

Just hooked up my new Fuze. Rhap recognizes it but when I right click on it in Rhap, I don’t have the option to authorize.  I have registrations left in Rhap.  I’m in MTP mode and media player 10.

Thanks!

Look at the listing in the sources pane in the Rhapsody 4 interface.  If your Fuze is listed all in CAPITAL letters, it’s in MSC mode.  To authorize, the device must be in MTP.

If it won’t authorize, and is listed correctly as Sansa Fuze 2GB, for example, there are two simple steps I’d try in your case:

On the Fuze, Settings > System Settings > Format > Yes.  This will clear all media from the device, but it also gives you a clean slate.

Be sure that MTP is working smoothly, and update WiMP10 to 11.  I find it to operate more smoothly, unless you’re also using Winamp (WiMP11 and Winamp compete for world domination).

Bob  :smileyvery-happy:

Hi,

Still unable to authorize fuze after doing the steps above. Its still listed in capital letters in Rhap.  I used the firmware updater and have the latest version and I’m using Media player 11.  Also, I noticed when I plug in the fuze that Rhap does not automatically launch like it did when I used the e260.  I have to manually open Rhap.

Ideas?  Thanks

Two issues are at play here, one in Windows, and one on the Fuze.

We need MTP mode for the Rhapsody account: with the Fuze disconnected, go to Settings > System Settings > USB MODE > MTP   to hold it in MTP mode.  In this way, we avoid Auto Detect reverting to MSC if there’s an MTP issue on the PC.

Go ahead and open a Windows Explorer window on the PC, by pressing the [windows key] + E, or via My Computer.

Plug in your Fuze.  It MUST be recognized in MTP mode, meaning that it will show in the window under “other devices” at the bottom of the list, as a media player. 

On the PC, you need Windows Media Player 10 or 11 to have MTP functionality, meaning at least Windows XP.

Does the device show up under “other”, listed without a drive letter?  If so, go ahead and right-click on the Fuze.  Let’s take a moment to configure it to automatically open Rhapsody, if you wish.  Select Properties.  There will be a tab in this window marked AutoPlay.  Click on the tab, and at this point, you can select the program desired to open with your Fuze.  I like “take no action”, personally, as I often simply want to charge up my Sansa without opening the R4 client.

Now, you can open the Rhapsody 4 client, and sign in.  Your Fuze will be listed as Sansa Fuze 2GB (variation depending upon your devices memory capacity), in caps and smalls.  Right click on the Fuze, and Authorize it.

If the Fuze doesn’t show up in MTP mode, that’s our next step: repairing MTP.

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 10-25-2008 12:37 PM

Thanks Bob,

But I’m still unable to authorize.  Sansa still shows up in Capital letters in My computer and in Rhap.  I’m using media player 11 with XP and the Fuze is in MTP mode.  Where else can I go from here?  You mentioned repairing MTP.   How do I go about doing that?
Thanks so much.

First, be sure to manually select MTP mode by goint to Settings > system Settings > USB Mode > MTP.

On the PC, open up a Windows Explorer window by pressing [Windows key] + E, or via My Computer.

Plug in your Fuze, and watch for things popping up in this window.  Does the Fuze show up under “other devices”?

Open the Device Manager.  You can use the cool shortcut [Windows key] + [Pause/Break key], or Control Panel > System > Hardware tab > Device Manager button.  Look for yellow triangles of doom!

If it’s trying to connect in MTP mode, look under the Portable Devices listing.  If you click on it, the Sansa should be there.  Double click on the Sansa, and select uninstall but NOT “disable” , as to disable is to tell your PC, “don’t worry about it.”

Now, if you unplug, try connecting again.  (I like to reboot the PC after uninstalling)

If the Sansa does not show up, let’s try giving WiMP a jump start.  If you have WiMP10, or WiMP11, reinstall or upgrade your Windows Media Player.

Download the MTP Porting Kit from Microsoft.

After EACH of these steps, all you need do is plug in your Sansa (In MTP Mode) after each step, and watch for fireworks (well, at least for it to show up in the Windows Explorer window).

Unplug the Sansa while updates are being performed.

Let me know how it goes so far…  ^z

Bob  :smileyvery-happy:

Hey Bob, It worked!  Thank you so much. You made my night.

 

Thanks!

 

I dont have the option to uninstall on the sansa part what should i do.

"If it’s trying to connect in MTP mode, look under the Portable Devices listing.  If you click on it, the Sansa should be there.  Double click on the Sansa, and select  uninstall  but NOT “disable” , as to disable is to tell your PC, “don’t worry about it.”

  1. Please don’t dredge up a 5-year old thread by posting in it. Start a new one one instead.
  2. Explain your problem in detail. More information is better than not enough.
  3. Are you sure your player is not set to MSC mode?