Cant use my Fuze...get "Synchronize to continue your music subscription" error

OK this is annoying.  I just posted the thread on how i reformated my fuze and lost the channels icon. 

I actually reformated the Fuze because it wasnt working anymore.  Rhapsody to go was working fine w/my Fuze for a while (i’ve been a die hard rhapsody/Sansa user for a while) … but then it stopped allowing me to play tracks.  I’d get this “Synchronize to continue your music subscription” error on every track even though i’d just added tracks/albums and synchronized things.

Tried everything from the reformat to deauthorizing and reauthorizing the device and even updating the licenses on my library tracks.

Any thoughts folks…at this point my fuze is a brick … i really liked it so please help me get it back to functioning condition.



Deauthorise device. deauthorize computer,  Reinstall Rhapsody,  Authorize computer,  Authorize device.

I think that will solve it. 

Hmm tried it but no luck…any other thoughts folks?  -Steve

Wouldst thou like Channels?

The correct folder data is missing.  I’ve had this happen to the Clip.  The problem is that the required data is missing, amd the Rhapsody client will suddenly drop the Rhapsody Channels option from the list.

Oh, and I wish you the very best of luck with RealNetworks tech support :wink:.  This situation is missing from their card set.

The simplest way to rebuild the correct file structure is to reinstall the firmware, following the directions in the firmware thread.  This should get things back to normal.

Please note that if it does not resurrect the Rhapsody Channels function upon reauthorization, I have further magic for you.  I’ll bet that you might have experienced my favorite PC poltergeist’s work: Windows Media Player.  WiMP likes to play with my Sansas.  It has corrupted itself when it “feels like it”, created phantom folders, stolen folders, turned the Rhapsody Channels into individual playlists, among other things!

What WiMP might very well have done to your Fuze is duplicate the Rhapsody or Service folders.  Rhapsody sees the empty subfolder, and assumes you have a v1 Sansa (e200) without Rhapsody Channels capability.

After you reinstall the firmware, a task you can do in MSC or MTP mode. The difference in MTP mode is that you must double click on the “Internal Memory” icon to expose the root directory for the .bin firmware file to be dropped within.  After downloading the firmware, unzipping the file, and dropping the file into the root directory of the Fuze, have a brief look around there.

You’ll see a group of requisite folders:

  • Albums

  • Audible

  • Music

  • Photo

  • Playlists

  • Record

  • Service

   - Rhapsody



Note that in this basic representation (- sign denotes open folders, easier to see then the actual Service\Rhapsody\Artist notation), there are TWO “playlist” listings.  The upper folder is for normal device playlists, and the second one under the Service folder is the Channels folder (yes! It is named “playlists” ) that allows the Rhapsody Channels to be entered within.

Have a look at your file tree in Windows Explorer / My Computer.  What you very well may see is a second (empty, without subfolders) phantom Service or Rhapsody folder.

Who duplicated the phantom?  WiMP won’t fess up to it, I guarantee you.  If you have a duplicate of one of these folders, poke around and delete the one that has no subfolders within it.

You may have a duplicate Rhapsody or Service folder.  The file tree should look like the one above.

Once you unplug, and allow the firmware to reinstall, plug back in and authorize your Rhapsody Channels (RhapPFS) compatible Fuze again.  The R4 client will now show Channels being available again!

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 08-15-2008 07:15 AM