Ultra+ 256GB error on first POST only

I deal with computer problems often, but this was a new one!

My Sandisk Ultra+ 256 (SDSSDHP256G) was purchased about a week ago, and comes bundled with the latest X2306RL firmware. I put it in a Thinkpad X200, and when it boots the BIOS shows a “Device Error” until I manage to soft-reboot the system. On the second POST, the drive is detected properly and boots fine. This behavior is consistently reproducable on every boot from power-off.

The X200 has this problem on both its original 2011 firmware and the latest 2013 firmware update. Apparently these run the Intel Montevina platform, so I’m curious if anyone else with a similar chipset has this problem.



Hi holiday,

you are not alone. I’ve the same problem with a complete other setup too (Toshiba X200 with Intel ICH8 Southbridge).

I think the problem is caused by the chipset not being able to understand the SATA3 interface standard. So the SSD tries to send SATA3 commands first, then falls back to SATA2 after the soft reboot. Had the exact same problem with an old PC and a newer HDD. Thankfully the hdd had a jumper for setting SATA1 mode and this fixed the problem.

So it would be nice when Sandisk would release a tool for setting the SATA speed permanently. Other manufacturers like Crucial did this already.

same problem here. When the system is ins standby it works perfectly, only when hybernation starts and i have to do a cold boot, it stops. I start the system, press F2 voor bios access and wait. Then go into the bios, esc out of it and it starts. Realy anoying

try disabeling HIPM


Hi stekman, have you tried disabling HIPM already? How did this work out for you?

Try the new Sandisk Ultra Plus firmware X2316RL. It worked for me.

I have exactly the same problem as Holiday. It’s quite annoying.
Update X2316RL seems to have been pulled I can’t find it anywhere. :confounded:

Lol it is really gone. I can upload it for you tomorrow. But the question is, why it was skipped. Hopefully there is no serious issue. But my SSD still works. Totally stupid to remove an update without telling any reasons!

Thank you, i will wait for an explanation though before i flash my SSD. It might be a technical issue. It’s weird that they didn’t give the reason for the pull, at least for those who already flashed. Hope we get news soon.

Here is the link, if anyone wants to take the risk: Sandisk Ultra Plus X2316RL firmware (This FW is only for the 256GB Ultra+ SSD. It cannot be applied to capacities other than 256GB)

Sadly if have just an iso version for burning on a CD.

To be clear: The firmware was withdrawed by Sandisk. The reason is unclear!

For me the firmware still works without problems, but this could not be true for other computers!

1 Like

On the german forum I found a description, why the firmware update was canceled.


On some systems the firmware update won’t start or even fail! So there is really a risk updating.

And wtf, why is there no edit button for a post on this forum?!

I have the same issue with my Lenovo T500 laptop, but I cannot flash the x2616rl version. It takes more than 1 hour without any update on the ssd.



Then you have the issue as specified in the official post :frowning:  I’m sure, the problem will be fixed after the holidays. So be patient.

The update pull explination is in the FW thread


" Notice for users that Previously upgraded to Firmware Version X2316RL

Some systems have a compatibility issue with the USB or CD-ROM bootable system image and the FFU does not start or fails during the FW update process. There are no issues with the firmware and if you previously upgraded successfully you will not be affected by this issue. While we investigate this matter, we have decided to remove the new firmware from the SSD Toolkit"