problem to upgrade ssd firmware

Hello everyone,

    I have a problem with my ssd SanDisk Ultra+ SSD SDSSDH2-256GB when I boot from CD or pendrive and select the drive for upgrade to the last firmware version (X2306RL) there’s appear a red windows saying “Firmware update of SanDisk SDSSDh2256g Failed”. My current firmware is X211200. I tried this in 3 diferent notebooks in usb case and into sata port and got same error. Also have another problem in windows 8, I dont know if this is a ssd problem or is the OS installation but sometimes I’m using the notebook (Ultratouch np540U3C samsung) and the screen turned like the next video:

that happened after the upgrade of my hdd to the ssd and use a fresh windows 8 enterprise x64 installation

Waiting for your answer and sorry for my bad english,



Same here with the same SDSSDH2-256GB on macbook pro. I boot from CD and the firmware update failed ever.


I have the same problem that you are testing on three different computers with two SSDH2256G? I applied the same two methods error.
Bios function AHCI enabled.
Well recognized by this motherboard SSD
Or is the problem?
Thank you the Sandisk support we answer


no, I only have one ssdh2256g. I mean that I’ve tested the disk on 3 differents computers In usb mode (enclosure) and in sata port (default hard disk on computer) and got same errors with pendrive and boot cd method. Also AHCI mode is enabled. The second problem that I have in windows 8 seems to be the memory ram. 

Waiting for an answer from Sandisk.




I have the same problem as you.You are not the only one with the problem.
SSD buy amazon last week.
I look like the answer you Sandisk.

if FW update fails you will need to contact sandisk support. 866-sandisk


I contacted support Sandisk France today, they will send me a mail with a procedure by phone they not give me an answer.
If I could find this procedure in the forum for those who have already had this problem it is faster than waiting to post that I think will be the same as their website you.

thank you

Tu pourras nous faire partager la procédure?


Finalement la meilleur procédure qu’ils m’ont proposé … est de renvoyé les SSD vers le SAV de la  République Tchèque (frais d’envois a vos charges,avec un délai important,).
Sinon passer par le Sandisk Support France il vous l’envoi au bout d’une semaine dix jours.
Moi qui utilise les ssd pour mon travail, délai trop long (une semaine a dix jours).
Je vais les renvoyer chez AMAZON qui ont un SAV DES PLUS REACTIFS (Sous deux jours) et je vous conseille sincérement pour vos achats (il vous envoi les SSD de suite !!! ).

Bon Courage à vous,



oui le coup du SAV en République Tchèque à vos frais (et très long) c’est le summum du n’importe quoi.

Personnellement vu les nombreux problèmes avec Sandisk je déconseille cette marque (surtout si vous êtes sur Mac)

I think I read that the CD with the updater software needs to be interrnal.  I removed my optical drive to external in favor of adding an additional hard drive (nice kit - better than the OWC one [no disrespect meant] - but the drive is much more secure in the holder).  Anyway, somewhere it said the firmware had to be updated using an internal optical drive.  Is this true?  And how critical is this firmware update?  Have been using this 256 GB SSD for many months now with no problems.  Don’t want to open a can of worms, or worse yet be stupid and not apply an updated that is needed to make the drive stable/etc.

Anyone out there with suggestions?  Or is my only option to reinstall the optical drive to do this?  I read somewhere also that to do this update the person suggested moving the SSD to another computer.

I’m running an early 2011 MacBook Pro, 2.3 GHz, 16 GB RAM, OS X 10.9.3 - if that is necessary to help with an answer/suggestion.

Thanks in advance…


just use this SSD Dashboard 1.2.0 to update it. it works for me