Transfering Playlists From Mediamonkey Problem - Clip+ 8Gb

Just bought my first Sansa Clip+, very impressed, but am having strange problems transferring existing playlists in Mediamonkey.

The Clip is in MTP mode, right click on the playlist in Mediamonkey and send to Sansa Clip (Synchronize).

This is a playlist of songs all from the same artist,

All is good, the tracks are all stored in their respective Artist/Album folders under the Music folder and the playlist appears in the Playlist folder, a total of 25 tracks.

Now the strange part.

When syncing another playlist for the exact same artist, the data tranfers correctly as before, the new platlist consists of 19 tracks, but when going back to check the previous playlist, it has been changed & now only has 14 tracks instead of 25!

If I sync that original playlist again, it corrupts the other one!

What’s going on?  I don’t get this problem on my Samsung Wave phone or iPop Touch.

It’s as if a track can only appear in one playlist at a time??

Thanks in advance.

are you using mediamonkey in the latter instance? I use my clip in MSC mode and this works well for me.

Hi Chuck,

Yes, I use MediaMonkey for all of my devices, normally without any problems.

It’s only playlists behaving oddly, transfering complete albums seems ok.

Are you saying you use your device with MediaMonkey, but in MSC mode?

I’ll play around some more later today.


Now using Clip in MSC mode with Mediamonkey.

Playlists now transfer correctly without corrupting one another, however, there is a problem, where after the sync, the playlists appear to be empty on the device.

Further searching reveals many people have this empty playlist problem, due to the Sansa devices requiring relative path playlists.

So, to overcome this, after syncing, I used a text editor to modify, (search & replace), the path data from \Music\Artist\Album to …\Music\Artist\Album.

It would be good if these problems could be fixed in a future firmware or a mod within Mediamonkey to avoid this extra step.

This has been bugging me for ages but I finally worked out how to get playlists onto my Clip+ through MSC.

You have to do 2 things:

  1. Export the playlist file (.m3u) to the root folder (not the “playlists” folder)

  2. Once it’s on the clip, open up the playlist file with notepad and delete the folder label using find and replace --> so find “D:\Music” and replace with “MUSIC”

D:\Music\Kitsune\Kitsune Maison #6\17 The Day We Fell In Love.mp3


MUSIC\Kitsune\Kitsune Maison #6\17 The Day We Fell In Love.mp3

Job done.

Alternatively, you could do it with FOOBAR whereby you don’t need to do step 2.

I searched my problem in google and have this exact same problem. It’s still not fixed?

You’re telling me that to make a playlist, I have to go through all this crap? I’ve had mp3 players from years ago and never have to do this.

I updated the firmware via and it now works!