The Clip Jam works....but wont mount. What's up?

My clip jam works ok…and when i connect it, it gets power…but I cannot get it to mount to add anything to it.

Anyone have ideas? I’ve tried different cords and reformatting it and nothing seems to work.

Hi there, I realize this is a late reply but just in case you check back or someone else has the same problem.

I’ve have this problem as well sometimes.  The device connects and says “charging” but I cannot transfer.  I’ve fixed it by cleaning the USB port on the device.  Sometimes I use the corner of a tissue dipped in alcohol to clean around the contacts, sometimes Deoxit.  I let the port dry for a few minutes, try connecting again and usually it works.  I repeat the cleaning if it doesn’t work on the first try.

Sometimes switching to a new USB cord works too.

Hope this helps.

having the same issue.  I am Windows 10.   I bought 3 Clip Jams for family members.  All worked great for a while.  Now I cannot get my computer to recognize the device.  Help!!   These 3 units are now basically worthless.

Yes, it’s the same issue on multiple Clip Jams.  Yes, it’s the same issue on different USB ports on my laptop.  Yes, have tried different cables.


Update on my issue:   Mea Culpa!  I had previously tried a second cable, with no luck.  But lacking other fixes, I scrounged around my house and rounded up 5 cables that I had laying around.  Out of the 5 cables, 2 of them work properly! So, 3 of 5 cables do NOT work properly, and 2 of 5 do work. And this is consistent and repetitive results.  Go figure.

In the attached photo, the 2 cables at the bottom are the ones that work properly, and the 3 at the top do not work properly.

Maybe take a quick look at this weblink. There are lots of online discussions of this common confusing situation.

Thank you!  That’s exactly what I was beginning to suspect, and just didn’t google it correctly to find that article.  That clears it up for me.