Sandisk device won't be recognized now.

having the same issue. I am Windows 10. I bought 3 Clip Jams for family members. All worked great for a while. Now I cannot get my computer to recognize the device. Help!! These 3 units are now basically worthless.

Yes, it’s the same issue on multiple Clip Jams. Yes, it’s the same issue on different USB ports on my laptop. Yes, have tried different cables.


Yeah, that sucks. These devices are SO compact it’s great, but now I bought AGPTEK or something due to Sansa problems…now my problem is I can’t find the AGPTEK! Anyway I see this is an old thread, but try

  • Let them all DIE. Battery totally dead. Now connect to the USB which might wake them up.

  • Try a different computer, different version of Windows. Try a Mac. If that connects maybe you can re-format.

Be really **bleep** careful to leave IIRC 500MB free space otherwise when it tries to refresh your media it bricks. Simply ridiculous crap.

same problem;  Mac Air does nor recognize Jam

In my experience and from reading messages in this Forum, this problem occurs when attempting to use USB cables that do not support data transfer.  The original micro USB cable that comes with the player should work.