drivers not working?

 I seem to have lost the drivers for my mp3 player. It started with my older San Disk Clip Zip. Thinking that the device had died, I bought a new Clip Jam, and am having the same issue with that one.

When I plug either one in to my desktop computer (Windows 7), it isn’t recognized, but both Clips still work on my laptop (also Win7), so I know it’s neither the cable nor the player itself. I’ve looked for help on the SD website, and tried the recommendations.

I’ve edited the registry, removing all possible references to SanDisk, though there were a bunch of them that couldn’t be deleted.

The usb ports still recognize other devices (phone, backup drive, thumbdrive), so it’s impacting only my mp3 player.

Things seemed to go bad after I plugged in a cheap bluetooth speaker for charging. I’m not sure if that’s what jacked my computer, or if it’s just an unhappy coincidence. It was working fine before I plugged in the speaker.

Also, when this first happened the device showed up in Device Manager as a “portable” device, but had the exclamation mark in a yellow triangle, saying there’s a problem with it. After I used RegEdit, it stopped showing up in Device Manager. 

I’ve done “scan for hardware changes” a bunch of times.

I don’t use Windows Defender, and I re-tried all of the previously-mentioned things with Norton Firewall turned off (it’s back on now!)

I’m getting by for now, loading up my daily listening on my laptop, but it’s kind of a pain.

Thanks in advance for any suggestions!

Here are two suggestions for you to consider.

  1. The article at this web-link looks to me to be really informative and posssibly helpful.

2I If none of those tips work for you, then maybe try upgrading to Win 10?

     Here is a web-link for the free upgrade from Microsoft. I find Win 10 to be very user-friendly. Each upgrade from Win 7 or Win 8 appears to be designed for the specific computer hardware capability.

Thank you for your response!

I have tried #1 - it didn’t work.   The USB ports recognize other devices, just not either of my two SD Clips. 

I’m trying to avoid Windows 10 (not sure why) - buy I may end up resorting to that. 

I can’t believe this thing is kicking my butt like it is!   I’m usually the one helping other people with computer issues. It’s very frustrating. 

Upgrading to Window 10 wont help as I’m having the same issues on Windows 10.

Is the USB mode on the Clip Zip set to MSC? If so, then the player should be recognized. If you want to use it in MTP mode, then I suggest that you reinstall Windows Media Player on your PC. Windows Media Player contains the MTP driver. 

I think the OP is referring to the new Clip Jam . . .

" It started with my older San Disk Clip Zip. Thinking that the device had died, I bought a new Clip Jam, and am having the same issue with that one."

The Clip Jam is an MSC-only device.

Just update youir drivers and fix this issue,  Start  button, type Device Manager and now click on update driver, If anything else, Just follow this blog will help you.

Stupid solution, but try to check your cable. Maybe it is broken? Had this issue with other devices and bad cable.