Strange Sound! Everything is noisy.


I have an Sansa Fuze 2GB refurbished MP3 Player and a 16 GB micro SD card.

I ordered the mp3 player and the first 3 months, everything was fine. 

Sound was good and clear. Now I have troubles with the sound. 

Now the sound is tinny and noisy. The difference is really extreme. Some voices are almost gone. 

I tried to put it on the factory setting and to reverse the mp3 player. Nothing helped.

I also tried different earphones. It was always the same. The plug connection seems to be also ok.

The headphones plugs perfectly!

I wanted to change the firmware, but I have already the newest! So with the updater software, it seems to be not possible.

What could be the problem?? What shall i do?

So, is it possible to put an old firmware manually or to reinstall the newest?

Usually that means the headphone ground pin is disconnected.  Try a different pair of headphones, make sure they’re plugged in tightly as can be, and if that doesn’t work replace the player.

As I have written in my first question, the connection between headphone and player is fine.

It fits perfectly. The same problem i also had with different headphones I tried.

What you are describing is the sound of the headphone missing its connection–you are getting the difference between the two channels rather than the combination of them. This often happens to new Fuze users who don’t plug their phones in all the way because the jack is so tight. But if it is an old Fuze then the jack in the unit itself may be going bad, and there’s no way to fix it.

Refurbs are always a gamble. Good price, but no warranty in case anything like this happens.

My max volume is so weak,all of a sudden it change into strange noises.Help.