strange problem with two Cruzer 32Gb flash drives on XP Pro

I have two Cruzer 32Gb drives which won’t work in one particular PC running XP Pro SP3.

The drives work in other PCs running XP Pro and PCs running Win 7.

Now before anyone says “well it’s obviously a problem with the one PC” I should say that USB Flash drives from other manufacturers works just fine in this PC, as does my Seagate FreeAgent Go drive (so it’s not a power issue).

The only flash drives that exhibit a problem are the Sandisk drives.

When I insert the Cruzer it flashes slowly then after maybe 20 seconds starts to flash rapidly and continues to do so while it remains inserted in the USB socket. There is no indication on screen that it has been inserted - nothing ofering to browser media, files etc.

The drive appears under My Computer as removavble drive F, but no files or folders are visible.

When I go into Admin Tools>Computer Management >Disk Management the drive is NOT visible, nor is it visible as a removable drive.

Under Device Manager it appears as SanDisk Cruzer USB Deivce, using a Microsoft Device Driver date 7/1/2001.

I have tried uninstalling this device, removing the Cruzer then re-starting the PC, but when I plug it in again it finds the new hardware - Sandisk Cruzer and Hard Disk Drive, but then says it may not work properly and prompts me to restart the PC. Afterwards it then reverts to the symptoms described above.

BOTH Sandisk Cruzer 32Gb drives exhibit the same problem.

Does anyone have any other ideas?

It’s not XP’s problem.  See the same problem with Windows7  as well… Works with my Windows 8 box.

Absolutely the same problem you see.  I just bought the thing this week at Costco.

See the other post about Samsung Kies and the Cruzer in Win7.  Might be my problem.

thanks pechter!

Kies was the problem.

I followed the instructions in this thread and it cured the problem.

I should point out that it didn’t affect any other brand of flash drive that I tried, the incompatibility appears to be only between the Sandisk Cruzer and Kies, which leads me to conclude that it’s a Sandisk problem.