SanDisk Cruzer causes computer to freeze

When I plug my 4 gb SanDisk into my XP computer, it freezes.  I have to shut it off with the start button.  My other SanDisk Cruzers work fine.  The problem 4 gb SanDisk works fine on another XP Pro computer, just not the XP Home machine.  How can I trouble shoot the problem.  This computer would not recognize any of my Cruzers and I found the fix on the SanDisk site.  The fix had me go into the registry and remove an auto run command.  That took care of the other curzers, but not the 4 gb one.  Any ideas to try?

I suggest you try finding a replacement OS since XP offically dies in April.  And the replacement OS may solve your Cruzer problem.

Sorry, but that is not an option I was looking for.  After all, for years it worked fine.  There is some kind of conflict with one of my XP computers and the Cruzer.  My 3 other Cruzers work fine and that problem one works fine on another computer.  I was hoping someone could tell me some things that could cause the Cruzer to freeze a computer.

Have you tried different USB ports? Maybe the one you’re using has gone haywire.

Yes, I have tried other USB ports.  My other Cruzers work in my normal port that I use.  Very strange how several work, but one does not.  I was thinking of downloading the files unto the computer on which it works, then trying it.  Can you reformat the Cruzers and re-install the software that it came with?

Yes, you can reformat the drive and reinstall the software, FAT rather than NTFS or exFAT.  I assume the software you refer to is SecureAccess?  Try deleting the app and then using the drive.  If that works try downloading the current version and installing that.  Do note that the install must be run from the USB drive.

Great, I will give that a try.  I was refering to whatever is on the stick from the factory.

I removed my files and Launchpad, then formatted the Cruzer.  No problem when I plug it in now.  There was something on it that my one XP computer had a problem with.  

Does Secure Access replace Launchpad U3?  I may load and try that.  

Since I bought these flash drives, I purchased two 1TB external hard drives where I back up all my files.  The important ones that need to be secured are saved in a vault using TrueCrypt.

You didn’t mention that this was a U3 drive.  Do you still have the U3 CD partition on it?  If so restore the file.

Is it possible the machine froze before because it was waiting for you to respond to the U3 password prompt?

Yes, SecureAccess is a replacement for U3 but it is a different animal than U3.  U3 secured the whole drive, SA is designed for securing files on the drive and IMO is slower than U3.