Cruzer Switch 64GB ERROR Stopped Working

After I put in my password I get an error message saying: SanDisk SecureAccessV2 has stopped working. Also get message choice to either Check online for solution (which doesn’t open any links) or Close the program. Under view Problenm Details tab also in Error Message it says the Problem Event Name is APPCRASH. Please can anyone help me reaccess my data?

Is anyone from the community able to help me please retrieve my data?

Have you tried the Switch in another pc Grego?  Or after rebooting your pc?

Thanks Ed_P. I have tried it now on 4 diffrent Pc’s plus my own rebooted but am still having the same trouble. Do you have another idea I could try please …?

hmmmm  Try running a CHKDSK command on the drive, reboot, and see if that helps.

If not you can try replacing the SanDisk app on the drive.

Thanks Ed. I would like to try this fixes. Sorry not I’m not overly technical: Is the drive my laptops one? Do you have any detailed instructions on the process? Much appreciation, Grego

Is the drive my laptops one? Do you have any detailed instructions on the process?

No, the drive I refer to is the USB one, ie the Cruzer Switch.

When you open a Windows Explorer window note the drive letter assigned to the Cruzer Switch.

Then open a Command Prompt window and in it enter:


where X equals the drive letter you found assigned to the Cruzer Switch.


Hi Ed, Thanks for your instructions to help be access the Snadisk Secure Access of my Cruzer Switch. I run the Command checks and got the message that Windows had checked the files and found no problems. I have rebooted my laptop but I am still getting the message : “SanDisk SecureAccessV2 has stopped working …Windows can check online for a solution to the problem the next time you log on. Options: Check online for a solution later and close the program, or Close the Program” when I try to enter my logon password. ie: I staill cant open the SanDisk drive.

If if helps I think the original error happened when I was trying to open two Cruzer Switches at the same time with my laptop.

Are you able to suggest another idea to try to fix the error/ problem?

With appreciation, Grego

Did you ever reinstall SecureAccess to the USB drive?

Hi Ed, Is this the down load from the web-link you sent me you want me to try;

Download SecureAccess (for Cruzer flash drives) :

 Download for PC (15MB)

I think this installs v3, but becuase I cant open v2 to copy my data to my PC and then into v3 I am not sure this is the download you wanted me to do. Is there another download to reinstall v2 you wanted me to try? If so can you give me the link as I cant find it on the web page. Sorry not quite sure which download I should be doing to reinstall the app. Or can I just delete v2 and install v3 without loosing any data on the drive? Or is there another approach? Thanks Ed.

I am not aware of a v2 download.  v3 fixes problems that were in v2 and may fix your problem but I understand your hesitation.  To be safe copy your USB files to your harddrive as backups.   Then I would install v3 over v2 on the USB drive, safely remove the USB drive, reboot and retry it.  If it doesn’t work you can copy the files backed up to the harddrive back to the USB drive.