8gb Sandisk Cruzer Switch - Vault doesn't open

When I insert my USB, I can only see 3 icons:

SanDiskSecureAccess Vault (a file folder full of DAT files),

SanDiskSecureAccessv2.0, another file folder with pdf manuals in it,

SanDiskSecureAccessV2_win, an application folder - nothing happens when I click on this.

What has happened? Is my disk corrupted? I have irreplaceable photos on this usb…


:smiley:   Hi Aussierich,

Please, are you on Mac or Windows?
Because, there are two different programs, one for each computer.


Windows here…

:smiley:  Hi,


Well, then, try in other PCs.



have tried…same result…

:smiley:   Hi Aussierich,

Sorry… SecureAccess corrupted.

But, if the UFD still works, you can try the following:

In _ Start/My Computer, _ in  icon on the UFD, click the right mouse button, and then click Properties/Tools/Error Checking and Repair.

Regards, Alfred.

:smiley:   Hi,

And then, other try.
Please, if you have any other UFD, empty, that works fine, try the following:

Load an new SecureAccess_win.exe, in this new UFD, and with _ same PASSWORD and USER, _  utilized in the previous vault of old USB.
Then, in this new SecureAccess, exchange the new vault, by the old vault encrypted (SanDiskSecureAccess Vault, “a file folder full of DAT files”), you have in the old UFD, with copy & paste.

Regards, Alfred.

Thanks Cacho - tried to fix via the Tools method, but it says I have insufficient rights to perform this task (!)

I’ll try your second method hopefully today and get back to you