Sandisk Cruzer won't download to Windows 7

Just bought a Sandisk Cruzer 16gb to transfer important files between my primary work computer and my new backup comp. The primary uses Windows XP, which I’m happy with and will not be upgrading until it rusts to death. The new one uses WIndows 7, which I’m willing to tolerate only slightly more than Vista. No problems loading my files onto the flash drive from XP, but the Windows 7 comp locks up every time I try to download those files from the flash drive onto it. I can view the files in Windows 7, and even alter them, but I can’t transfer them for some reason. 

So, I began experimenting. It’s only when I try to load info from the flash drive to a computer running Windows 7 (any computer) that it locks up. And it’s only this brand of flash drive that has that problem. My old Kingston works just fine, so it’s not likely the computer that’s having this issue. Little help? I

Try checking the Win 7 machine’s UAC settings and AV settings.

I have a similar problem with the SanDisk Cruzer 8gb (SDCZ36-008G) and Windows 7.  When I plug it in, it just flashes a red light.  The computer does not even recognize it.  The above answer saying to check the UAC and AV settings is a bit cryptic for this non-tech person…  Can you elaborate?  I checked my UAC settings and nothing obvious looked out of line.  I don’t know about AV settings, so that is meaningless to me without a little more direction.  My husband just got a new Kingston 8gb flash drive and it worked like a charm on my computer.  What gives with the Cruzer and Windows 7???  Please, can someone be a little more helpful about what to do here?  If there is no simple solution, I have no alternative but to return the Cruzer and get something else.  I have always been very happy with my SanDisk Compact Flash and SD cards, so assumed SanDisk was the way to go in a flash drive.  I’d love to use the Cruzer, but I don’t want to jump through a bunch of hoops to do so when all I have to do is get another Kingston…  Any help would be appreciated.  If not, the Cruzer is going back.  Thanks for any help.

IF your Cruzer is new I’m not sure what the problem is. 

IF your Cruzer is older and has U3 software on it and your Windows 7 is the 64-bit version rather than the 32-bit version run the U3 Launcher in Windows 7’s Compatibility Mode for Vista.  To do that, with the USB stick plugged in, open Windows Explorer, find the Removable drive, dbl click on it, move your mouse pointer to the .exe file, a RIGHT click on it, click on Properties, then click on the Compatibility tab.  You should be able to figure out what to do at this point. 


What gives with the Cruzer and Windows 7???”

Many USB drives contain no software thus work with Win 7 without problem.  Your SanDisk has software installed on it.

Microsoft chose to make two version of Windows 7, one is 32-bit based, one is 64-bit based.  90% of the people don’t need a 64-bit OS.  90% of the apps most people run are 32-bit.  U3 is a 32-bit app and SanDisk never developed a 64-bit version of it.

Thanks-- that explains my problem.  Because I am a heavy Photoshop user, 64 bit was recommended for me by an IT person.  That probably also explains why 3 out of 4 of my Compact Flash card readers don’t work on this lap top as well…  Thanks for your time and explanation. 


Glad to have been helpful Zoe.

If something doesn’t run in Windows 7 it’s usually due to Windows 7 being 64-bit.  I have both Windows 7 32-bit and 64-bit.  EVERYTHING that I ran on XP runs on the Windows 7 32-bit system.  Most XP apps run on Windows 7 64-bit without problems but some required some work to get them to run, missing OCX files and alike, or finding the right Compatibility Mode, but eventually everything ran on the 64-bit version except for 1 app that I had to replace.

FWIW There is nothing in this Photoshop requirements page saying it requires a 64-bit OS.

In case anybody is following this thread:  I totally agree that Photoshop does not require a 64-bit OS.  It worked well on my old machine with XP.  Photoshop definitely works faster on Windows 7 Pro 64-bit, however.  A casual Photoshop user might not see much difference, so 32-bit would be just fine.  When working on multiple large files at the same time, the 64-bit is faster and helps with the work flow IMO.  There are some studies that say up to 15 times faster.  Even the 64-bit can bog down when things get enormous, though.  Nothing’s perfect…



Without trying Windows 7 32-bit on your machine it’s hard to say the boost in preformance you’re seeing is due to 64-bit or simply Windows 7. :wink:

Did you upgrade an existing machine to Windows 7 or buy a new machine with it installed?

Good point!  My experience was XP to Windows 7 Pro 64-bit.  Word on the street is that Windows 7 64-bit is faster than Windows 7 32-bit when working in Photoshop, but I have not personally tested it between the two.  Like I said, I’m sure the casual user would not need the 64-bit.  I could have lived without it, but the IT person who recommended it to me knows the type of work I do, so thought the 64-bit would be better for my particular circumstance.  I have been happy with it except for the fact that I can’t use my SanDisk Cruzer 8GB and some of my Compact Flash readers…

I bought a new machine with Windows 7 Pro 64-bit installed, so no upgrade. 


I’m not aware of any of the major pc manufactures offering Windows 7 in anything but 64-bit mode.  There must be some kind of deal Microsoft has that makes it the preferred version for them.  And I think most of your happy experience with your 32-bit app is due to your new machine’s faster processor, more RAM and etc.  If/when Adobe develops a 64-bit version of Photoshop you will be in position with your new machine and 64-bit OS to utilize it’s expanded capabilities to their fullest without having to buy yet another new machine.

Hopefully you are now able to use all your USB sticks.

I have an i7 and 8GB RAM, so I’m sure that is responsible for some of the speed.  Apparently, when you load Photoshop (CS4-6) onto a 64-bit machine, both 32-bit and 64-bit are installed.  (Reference:   I have been using the 64-bit Photoshop program, so that may have something to do with the speed, as well as the upgraded processer amd RAM.

Unfortunately, no luck with the SanDisk Cruzer . . .

Thanks for your suggestions, though!


Windows Vista (Service Pack 2) compatibility mode for LaunchU3.exe doesn’t work for you!!  Do you get an error msg?

I can get the Cruzer to show up under Devices and Printers, but even when I log in as Administrator, I do not get a Compatibility Tab when I right click on Properties.  I’m also not seeing an .exe file.  Am I looking in the wrong place?  Sorry to be so dense about this…


:smiley:  Can you get the Cruzer to show up under Computer?  And if you can can you dbl click on it?

No-- it does not show up under Computer.  Is it DOA?


Is it DOA?”

No.  If it shows under Devices and Printers it should show up under Computer, as Removable Disk (*: ), with * being it’s drive letter.

I know it should show up under Computer-- but it does not!!


hmmmmm On my Win 7 system, under Devices and Printers my U3 drive shows up as Cruzer Micro.  Under Computer it shows up as Removable Disk (I: ). 

Ok, with your U3 drive plugged in RIGHT click on Computer then click on Manage. 

When the Computer Management window opens click on Disk Management,  Do you see a Disk 1 and Disk 2 beneath the Volumes portion of the window? 

Within the Computer Management window click on Device Manager. Then click on the Disk Drives item.  Do you see entries for SanDisk U3?

When I click on Disk Mgmt under Computer Mgmt, I get a Disk 0 Basic, 232.88GB, Online and Disk 1 Removable (F:), No Media

Under Device Mgr and Disk Drives, it lists SanDisk Cruzer USB Device.  It supposedly has an updated driver and is supposedly working properly…  No Compatibility tab.


Yes, sorry, you should have a Disk 0 also, it’s your machine’s harddrive.

Disk 1 showing No Media is normal also if you have a U3 Cruzer and it has a password set.

No Disk 2 is a problem.  It indicates the U3 CD drive isn’t being recognized.  Having a single SanDisk driver entry under Disk drives isn’t encouraging either, especially since it isn’t a SanDisk U3 driver.