Strange Error Message

Hello, I get this error message that says, “Not enough space for music DB. Please free 200mb.”

The name has also changed for the device, it now says “SANSA CLIPZ”. (usually just said “Clip Zip” I believe) 

I literally just used it today, and just added music and then this happened. its a 4GB, has a 32GB microSD card. When I go to WMP or open the folder, it says there is no music on the device, yet it says the device is full. The MicroSD card is fine, put it in something else to check. 

*EDIT* So after fiddling with it and plugging/unplugging, its working again. Very strange though, will keep this up if anyone else has the problem or if it happens again. 

I have the same message on mine.  I’m not much of a geek but I’ve had multiple Sandisk clips over the past several years (I tend to lose them in airports, or drop them in the toilet).  Recently got a Zip to replace a clip that finally died.   It worked just fine for several weeks.  Then before a trip to Hawaii I loaded the player and card (which I’d never used before) with playlists, including a book that I was halfway through.  I plugged it into the rental car USB port but couldn’t figure out how to control what was playing since the working screen was now on the car dash and no longer on the player.  I unplugged it to see if I could figure it out and it totally stopped working- wouldn’t turn on, nothing.  Thought the car had totally fried the Clip but after leaving it for a few days, then recharging for a while, it turned on but only showed 2 songs downloaded (neither of which I recognized so they might have come already downloaded on the player when I bought it).  It showed the same 2 songs with and without the micro SD card.

Finally got home to my computer today hoping to reload the player, assuming that everything had gotten wiped off of it somehow.  I now get the message “not enough space…” and the player turns off, yet WMP is showing that there are no files on the player. 

Tried holding down the power button for 20+ sec’s.  Also uninstalled the program from the computer but when I tried to reinstall the little CD I got a message on the computer saying that there was “not enough space…” and I needed to delete 200MB.  I thought the CD had to do with installing a program on the computer, not on the player!  Very frustrating!  Glad yours is working again.  I’ll try a few more incantations while I look for the receipt to return the thing.

Thanks Tapeworm, I’ve got it working again!  Now I just have to figure out the next problem- the Zip doesn’t have an option for playlists, even though I’d sync’d them in that form.  I’m pretty sure I was able to pick on “playlists” before it froze.  Back to the Forum I guess…

I just figured out the problem with the missing “playlist” option by reading about other issues on the Forum.  Had to do with the USB mode, which I still don’t grok, but hey, it worked!