Stopped reading tags and error

My clip has never had any problems before. All of a sudden, it reads albums as “Unknown” but still reads the track tags. It read them perfectly before but now it doesn’t. I’ve formatted it several times, tried the 30 second hold, and reset everything. Also when I disconnect from the computer, it says that the device stopped working or that there was a data loss error or something.

Try running ChkDsk to look for and fix any corrupted files.

Everything’s fine with the system. Still isn’t working though.

Now whenever I connect it, it asks me to scan for errors but there aren’t any.

Did you run ChkDsk in MSC mode?


I would format it then, clearing it’s memory.

I did that several times and it didn’t work.

How exactly did you do it? Format, that is.

I go to format under the system menu. I tried downgrading the firmware and then upgrading it again but now whenever it turns on it says “Not enough space for music DB, please free 30 mb” and there isn’t even any songs. I can’t upgrade any firmware either now x(

Edit: I had to reformat it using windows explorer and I can now turn it on but it still has that **bleep** tag problem.

Message Edited by d_headshot on 05-07-2009 07:25 PM