Sansa Clip+ Problems, Correct Tagging But Unknown Folders and Jumbled Tracks. HELP!!

Hi Guys,

Can anyone out there please offer some advice to me and my husband before we gone completely insane?

We bought for our daughter the Sansa Clip+ but we are having the same problem happen over and over again.

When her music and audiobooks were first loaded onto it everything was fine. The items added were displayed in the correct places and folders but now for some reason when we add anything, the album folder may be visable but it also creates an additional folder which displays as ‘Unknown’. When you go and try to play from inside that folder it doesnt work…We always make sure that there is correct tagging we use MP" Tag,  so I know that the issues aren’t because of that.

We have tried EVEYTHING we can think of. Tried updating but I think we already have the latest version installed anyway - V01.02.18P, Performed a Factory reset, Formatted and tried using the different modes but it doesn’t make any sense. Why was everything fine a couple of days ago and not now…

We are using a 16GB Kingston SDHC Card inside the Clip+.

Please any ideas would be welcomed as this is becoming a nightmare.

Thanks Claire x

I have to add that I am beginning to think I may have purchased a FAKE SD card as the writing is rubbing off the front of the card… IS this likely and if so could this cause the issues I am currently experiencing? Xx

Problem was as suspected, it was a fake SD card. Genuine card inserted and problem totally solved. X

I’m glad and I’m sad.

Glad you were able to figure it out, but sad you got burned on a counterfeit card.

:smiley:   :cry:

Did you buy it off someplace (or body) on eBay? If so, _ definitely report them _ (the seller I mean)! This has been a problem for years now. EBay doesn’t know and can’t do anything about the problem unless people (ripped-off buyers) bring this fraud to their attention. :angry: