Files in My Internal Memory Won't Have Any Tags?

Hi, this is my first post and I apologize if this has been touched upon, but I have a 32 GB microsdhc card with my Sansa Clip+ 8GB and i love it. Plenty of songs, but I have almost another 8 GB to put music on the player. I don’t know why, but whenever I drag music in the internal memory it all shows up as “unknown” and it’s really annoying. I’ve tried dozens and dozens of albums and they all show up as “unknown”, but when i remove them and put them on the microsd card it shows up with tags and everything. is there a better alternative than going to: folders > internal > music > folders with no tags? Any help would be much appreciated! Great product!

Sansas can’t read every kind of tag. They can only handle ID3v2.2 and ID3v2.3 . 

So get  mp3tag, a free program.

When you install it allow itself to be added to context menus.

Under Tools set its Write to ID3v2.3 ISO-8859-1. The ISO is how Windows displays the alphabet, as opposed to UTF on Apples.

Find the album that’s not showing up, right click, use mp3tag under the choices to open it.

Highlight all the files and (under Files) just Save them, which will convert them to ID3v2.3 ISO-8859-1.

Mp3tag will show you what version the existing tags are, if you’re curious.

I like to change the copy of the album on my computer, delete the one on the Sansa and send a copy of the fixed one over, but you can fix  the one on the unit if you prefer. The database will refresh when you unplug, which will take a while with all those gigabytes, but it’s probably worth trying with one album first. If that works, then run all the others through the same process and

1 Like

Thank you! I’ll try this right away and if it works I’ll delete this post…in replace with a bigger thank you, of course. =)

Thank you for your help! It worked great.