Stop button not responding

When I tried to stop an mp3-audiobook while listening, the stop button didn’t respond. I have had my clip+ for a week now and this happened for the second time. The first time it happened, the display showed the stop symbol, two vertical lines, but the sound just continued. The second time the sound didn’t stop and the display also didn’t change. What helped in both cases was to connect the player to the PC and then unplug it again. After that the button functioned normally. But I can only do that when I am near a PC, so it is no solution. What might be the reason?

I am thinking of returning the device to the seller. Any advice?

You could try downloading the latest firmware and installing it manually on the player. The firmware in the player may be corrupted. The issue of the pause button not working can also result from pressing the pause/play button before the player fully boots up.

And if it happens again, you could try a system reset (at the time): hold the on button down for 20-30 seconds or so. Hopefully, though, the firmware reapplication tip noted above will fix matters.

Thanks for the quick response. I updated the firmware immediately (manually) and hope for the best.

After installing the latest firmware 5 days ago it happened again today: I press stop, display shows stop sign but the sound continues. I connect the player to the PC and the sound stops. After that the button reacts normally again. So the firmware update didn’t help. The player was already fully booted up and playing for a while when it happened.  Any more suggestions?

Do you wait long enough after turning on the player before pressing the play button? Try waiting a bit longer next time. Do you pause the player before turning it off? If not, then try that.

I have a new player and have experienced the same problem while listening to audio books. After reading the responses I think I’m probably hitting the play button too soon. But I have found a pretty easy fix for it as well. Just hit the power button. It turns off, and when you turn it back on again it will start playing automatically, but the stop button will be working once again. No need to hook it up to the computer or reset the unit. At least not with mine.


OK, it happened again. I returned the player to amazon and received a new one. Same model. Have had it one day and the same malfunction! So I gather it is a general problem with all clip+ players. @JK98 It didn’t result from " pressing the pause/play button before the player fully boots up" as I had already been listening a while. And yes, I “pause the player before turning it off”. Or I pause and it turns off by itself after a while. @Miikerman Yes, “system reset (at the time): hold the on button down” helps, but having to reset every day, over and over again cannot be right for a new product? My guess is it has something to do with the software, there must be a bug. Is there a place to officially report this and request a fix in the next firmware update? Otherwise I am quite happy with the functions the clip+ offers.

>>@JK98 It didn’t result from " pressing the pause/play button before the player fully boots up" as I had already been listening a while.

Give JK98’s advice another try.  If you press the play button even a microsecond before the splash screen disappears, it will behave exactly as you describe, I’ve done it many times - the play/pause button doesn’t work until you restart it.  Your keypress starts it playing so you may listen to it for an hour before you realize there’s a problem, but the play/pause button is already stuck. Once someone pointed this out, I realized I *was* hitting play without looking at it so it possibly wasn’t booted yet. 

It’s very easy to duplicate the behavior you describe by intentionally hitting play too early, it’s a bug, and yes, they should fix it. (I’m not holding my breath.)  ClipZips do it, too.

This thread is insane.  This bug is well documented.  Over a dozen posts about it.  I think it needs a very long mp3 file.  And sansa has not fixed it yet after 2.5 years.  Amazing.