short cut from MSC to MTP mode

I’ve had problems with MTP mode corrupting files at times, so I’d rather avoid Microsoft’s

nonsense and use MSC mode (as many posts recommend). However, there are times I

still need to connect in MTP mode (like to use the Sansa Media Converter).

I’ve seen many posts about how to connect in MSC mode if the Fuze is set to Auto/MTP

by pushing the power switch to Lock and holding down the |<< (left side of wheel).

Although that works fine for doing that… Is there a way to the the reverse?

By that I mean, is there a way to leave the Fuze set to MSC mode, but force it to

connect in MTP instead (for the few times I need to)?

I really don’t know why Microsoft has to keep mucking up stuff with their weird and

confusing nonsense all the time. Life would be a lot easier without their foolish nonsense.

@miltst wrote:

I’ve had problems with MTP mode corrupting files at times, so I’d rather avoid Microsoft’s

nonsense and use MSC mode (as many posts recommend). However, there are times I

still need to connect in MTP mode (like to use the Sansa Media Converter).

 

I’ve seen many posts about how to connect in MSC mode if the Fuze is set to Auto/MTP

by pushing the power switch to Lock and holding down the |<< (left side of wheel).

 

Although that works fine for doing that… Is there a way to the the reverse?

By that I mean, is there a way to leave the Fuze set to MSC mode, but force it to

connect in MTP instead (for the few times I need to)?

 

I really don’t know why Microsoft has to keep mucking up stuff with their weird and

confusing nonsense all the time. Life would be a lot easier without their foolish nonsense.

 

I haven’t used SMC in months, in fact I don’t even have it on my computer now, but I could swear that I used it in MSC mode just fine. :smiley:

I’ve used SMC with MSC, no problem. The only reason you should need MTP is for subscription services.

I had thought that SMC required MTP mode like the Sansa Updater.

Apparently I was wrong. Thanks for correcting me.

Since updates don’t come out very often anyway, and I can do them

manually I don’t really need to keep the Sansa Updater installed.

And, I won’t be using any subscription services or DRM’ed music, nor

do I ever plan to use Windows MediaPlayer to do any syncing (I don’t

like anything from Microsoft anyway).

As I had mentioned, I had several files get corrupted when using MTP

mode and the player would lock up in the middle of some songs because

of the corruption. I don’t remember if it ever happened when using the

Internal memory, but I know for sure it has happened to me several

times with External uSDHC cards (and it was a problem that was

repeatable also).

I suspect that the majority of lock up problems people are having with

the Fuze is do to files getting corrupted by MTP.

As long as SMC will work with MSC mode, then I’ll just switch the Fuze

to always use MSC, have it re-format itself (to wipe out any stuff that

got put on via MTP), and very likely live happily ever after (without MTP).

@miltst wrote:

I had thought that SMC required MTP mode like the Sansa Updater.

Apparently I was wrong. Thanks for correcting me.

 

Since updates don’t come out very often anyway, and I can do them

manually I don’t really need to keep the Sansa Updater installed.

 

And, I won’t be using any subscription services or DRM’ed music, nor

do I ever plan to use Windows MediaPlayer to do any syncing (I don’t

like anything from Microsoft anyway).

 

As I had mentioned, I had several files get corrupted when using MTP

mode and the player would lock up in the middle of some songs because

of the corruption. I don’t remember if it ever happened when using the

Internal memory, but I know for sure it has happened to me several

times with External uSDHC cards (and it was a problem that was

repeatable also).

 

I suspect that the majority of lock up problems people are having with

the Fuze is do to files getting corrupted by MTP.

 

As long as SMC will work with MSC mode, then I’ll just switch the Fuze

to always use MSC, have it re-format itself (to wipe out any stuff that

got put on via MTP), and very likely live happily ever after (without MTP).

 

Actually based on thgis post the problem sounds to me like it is the card and not the file itself or MTP mode. How old is your card, what brand, what size, where did you get it? If the card is going bad then it will look like the song is corrupted when infact the sectors on yout card are going bad.

@miltst wrote:

 

As long as SMC will work with MSC mode, then I’ll just switch the Fuze to always use MSC, have it re-format itself (to wipe out any stuff that got put on via MTP), and very likely live happily ever after (without MTP).

 

Sounds like a good plan to me! :smiley:

And for the record, SMC works fine in MSC mode for me too.

@conversionbox wrote:


Actually based on thgis post the problem sounds to me like it is the card and not the file itself or MTP mode. How old is your card, what brand, what size, where did you get it? If the card is going bad then it will look like the song is corrupted when infact the sectors on yout card are going bad.

At first, I too originally thought it might be a flaw in the memory card. BTW it’s a 4Gig SanDisk uSDHC card, so we can rule out any kind of compatibility problems of some other manufacturer.

Now, it would be too long to try and explain every step or test I did, but basically I switched to MSC mode and ran chkdsk /f. It would fix/find 3 problem files, then connect back in MTP mode, delete those 3 files (after the chkdsk fix), and copy them from my computer again in MTP mode.

I repeated that same general sequence 5 or 6 time with sometimes deleting just single files and replacing them, other times deleting whole folders and replacing them, and after each time around I’d switch back to MSC and run chkdsk… and regardless of what order I deleted or replaced the files or folders, chkdsk was always showing a problem (and basically with the same exact files each time also).

 At that point it thought… well, it _could_ be a flaw in the memory card, but it _could_ also be a flaw in Microsoft’s MTP or SanDisk’s working around MTP for an External memory card. So, in MTP mode I deleted all my files from the card in the Fuze, changed to MSC mode, and then did a bulk copy of all (over 3Gig) of my files all in one shoot back onto the card (instead of copying only a few things in steps like I had done with MTP). Then ran chkdsk again, and it did not find _any_ problems at all.

Now, this does not totally rule out a possible problem with the memory card, but it sure does look like there is something fishy going on with MTP mode that does not seem to occur with MSC mode. If I _do_ run into any problems in the future with using MSC mode, I’ll try to remember to come back to this thread and post what happened.

Personally, I don’t trust anything from Microsoft to work right. They have a bad track record (dating back all the way to DOS before Windows) of taking something that originally actually did work flawlessly and royally screwing it up lol. But, this _could_ also be some kind of bug or flaw in the way SanDisk has tried to work around MTP with External memory cards (since I don’t remember having had this problem with the Internal memory).

It would be interesting if someone is this forum (or at SanDisk) could track all the people that mention have their Fuze lock up and if it could be found that they were all using MTP mode (and that chkdsk in MSC mode also showed problems). But, that would take a lot of time to find out.

However, we’ve gone way off track here and still have not gotten an answer to the question (when I started this thread)… So, back to that… Is there some shortcut method to switch to MTP mode when connecting the Fuze when it is set to use MSC mode?  I know how to make it connect in MSC if it’s set to Auto/MTP, but is there a trick than can do things the other way around? And, just how many other tricks are there by holding down different button positions when plugging it in?

Message Edited by miltst on 02-26-2009 11:26 PM

I am new to all this, so ignore if this is stupid.

On my Fuze it appears I can change this setting:

Home -> Settings -> System Settings -> USB Mode

Not exactly a shortcut, but I think you just wanted the ability to do so.

I have recently used the updater, so perhaps this was recently added as an option.

@hertnekytjh wrote:

I am new to all this, so ignore if this is stupid.

On my Fuze it appears I can change this setting:

Home -> Settings -> System Settings -> USB Mode

Not exactly a shortcut, but I think you just wanted the ability to do so.

I have recently used the updater, so perhaps this was recently added as an option.

Thats exactly right and all Fuze’s can do that. What the origional poster was reffering to is a way to force your fuze into MSC mode when you are plugged in and connected in MTP mode. And they were wondering if there was a way to do the oposite. I would not suggest Forcing the fuze to MSC while plugged in ( I dont think it hurts but why take a chance) unless you have to, its easier IMO to do what you are suggesting.

I was not asking how to “force” it to change while it was plugged in. If the Fuze is alread set to Auto/MTP mode, you can hold down the |<< button while you plug it in to make it connect in MSC mode instead of MTP. What I was asking is if there is some similar trick to do the opposite. By that, I mean setting the Fuze itself to always connect in MSC and if there is some special trick or key that can be held while plugging it in so that it connects in MTP mode (instead of MSC).

I suppose I could just try holding down different button positions while plugging it in to see what happens, but I didn’t want to accidently end up with it going into some debug or diagnostic mode (if there are such things with the Fuze) and not know how to get out of it.

@miltst wrote:

I was not asking how to “force” it to change while it was plugged in. If the Fuze is alread set to Auto/MTP mode, you can hold down the |<< button while you plug it in to make it connect in MSC mode instead of MTP. What I was asking is if there is some similar trick to do the opposite. By that, I mean setting the Fuze itself to always connect in MSC and if there is some special trick or key that can be held while plugging it in so that it connects in MTP mode (instead of MSC).

 

I suppose I could just try holding down different button positions while plugging it in to see what happens, but I didn’t want to accidently end up with it going into some debug or diagnostic mode (if there are such things with the Fuze) and not know how to get out of it.

 

To answer your first paragraph…not that I’ve ever heard of, but I don’t know everything. ANd your concerns with different button combinations…who the heck knows? I’d be concerned too.