Connecting to computer

Please help…

I have connected my fuze to my computer in MSC mode. Neither “auto detect” nor MTP seem to work. However, in MSC mode, the computer shows two drives. I realize that one is the memory card which I am not using at this time, but it does not detect any files in the onboard memory. I have several songs loaded which play just fine w/o the computer but when connected, seem to dissapear. I had loaded them prior to my recent “crash” and now with a new hard drive, it’s not working. Am I missing a driver or some other file?

If you can see the two drives, you don’t need any extra drivers. In fact, they don’t exist.

Perhaps your Fuze has filesystem issues. Seeing there is nothing on it at the moment, I would try formatting it from the menu on the Fuze. After that, copy some unprotected files (no DRM) to the Fuze and see if they show up.

Good luck!

I’ve heard here before on the forum that files loaded in one mode, such as MTP, cannot be seen when in the other mode, like MSC.  Maybe that is why you can’t see your files anymore from the computer, but they play OK on the fuze.

Well I hope you haven’t formatted yet, because that would erase the songs that are there.

sepool is right about the USB mode. 

Go to Settings/System Settings and switch the mode to MTP. Your files are probably there–especially if you sent them over via Windows Media Player. 

The drivers for MTP mode are in Windows Media Player 10 or 11. My guess is that your new installation rolled back to WMP 9–which was standard with Windows XP. So you need to get a newer WMP (free from Microsoft) to use MTP mode. 

Don’t use Auto Detect. Choose one mode (I prefer MSC, which as you’ve seen is much more flexible) and stick to it. 

Message Edited by Black-Rectangle on 12-11-2009 08:56 AM

You are much better at reading between the lines than I am, Black-Rectangle.

Yes, if you filled your Fuze set to MTP before, and reinstalled XP with WMP 9, then formatting is not your first choice :slight_smile:

(Then again, if you still have copies of your files, formatting and switching to MSC is still not the worst thing ever. All you’d need to do is copy over the files again)

Thank all of you for your help. I am running WMP 11 but it just doesn’t want to see the existing files. Oh well, it automatically sync’d over all the music I loaded since the new hard drive so as long as it plays in my ears, I’m happy!

Any explaination for why it only sees in one mode and not the other?

The two modes can do different things.

MSC is straightforward drag-and-drop, like the unit is just a flash drive.

In MTP mode, Windows Media Player can send over the ultra-secret hush-hush I-could-tell-you-but-then-I’d-have-to-kill-you codes attached to media with DRM (Digital Rights Mismanagement), like files from Rhapsody or Napster or audiobooks from libraries.

Apparently they need to be kept separated from your computer’s point of view, probably to prevent you the user from fiddling around with the DRM information. But the Sansa reads everything from both modes. 

Some players are MTP only, some MSC only–SanDisk was trying to build in flexibility by having both. But since not everyone reads the manual, it ends up confusing people 

You can drag and drop in MTP mode as well, just like MSC.  MTP mode was designed to look very similar to the more basic mode.

In MTP, you can also create playlists via a right-click.  

Bob  :smileyvery-happy: 

neutron_bob wrote:

You can drag and drop in MTP mode as well, just like MSC.

 

Bob  :smileyvery-happy: 

Indeed, that is how I manage the content on my one MTP-only player. You are a wise man,neutron_bob! :wink:

Okay, I get that…Now I need to figure out why the computer is not seeing the device when in MTP mode. When I connect, I get the little pop-up window at the bottom right that recognizes that a new device is connected but then says that the installation failed and it might not work properly. Then when I open WMP (v11) it is not seeing the device. So…now what???

When that happens, try going into Device Manager (in XP it’s Start/Settings/Control Panel/System/Hardware/Device Manager) and look for a yellow triangle with an exclamation point, and uninstall if you see that. Then disconnect and reboot. 

There are other Windows tricks at this link:

http://kb.sandisk.com/app/answers/detail/a_id/42/session/L3NpZC9BVHhGWmZQag%3D%3D/sno/0