A Problem With Transferring Songs With The Fuze

Greetings folks. I’m having a problem with my father’s Sansa Fuze MP3 player, and I’m rather confused. It seems to be one of those common MTP/MSC problems. Here’s the thing, when I originally hooked up the MP3 player for him, I know it was in MSC mode because that’s the mode that is similar to a flash drive. I showed him how to transfer the songs onto it. Now we recently had to get the computer basically re-hauled, upgraded, new motherboard and everything. I’m attempting to set it up for him to put songs on it.

 

However when the computer is in MSC mode, there’s no songs, nothing, nein, notta. However if I switch it to MTP mode, the songs are there. But I know I never transferred anything using WMP because I prefer the simple “drag and drop” method using Windows Explorer.

 

So it seems that now I’m stuck with a bunch of songs on my Dad’s MP3 player that can’t be put back onto the computer, and that he can’t access unless it’s through WMP. Is there any way to correct this?

Thanks in advance.

Message Edited by TomJensen on 05-03-2010 05:30 PM

I do appreciate the reply. Not to be rude though, but if the drag and drop was still working in MTP mode I wouldn’t have made this post. As it stands if the player is in MTP mode, it just gives the option to move songs using WMP, nothing appears in Explorer.

 

When I first put the songs on there, it was all drag and drop in Explorer. I didn’t even know about MTP/MSC at the time. All I want to do is to keep it simple for my father. I showed him a certain way of doing it and I want to keep it that way. That’s in the MSC mode, but the songs already on the MP3 player should be showing up in MSC regardless as that’s the mode the player was in when I originally put them on there.

Message Edited by TomJensen on 05-03-2010 05:17 PM

Well I may be getting the two modes mixed up. Regardless though, the songs were put onto the Fuze originally via drag and drop, and now they are unable to be put back onto the PC via the same method. And the songs on the Fuze only show up in WMP, and unfortunately WMP does not allow the songs to be copied back to the PC.

 

And as stated originally, we had to basically get a new computer. New motherboard, formatted hard drive, the works. So the songs on the hard drive are not there any longer. Which is unfortunate.

 

It seems that my only solution may be to just re-download all the songs that are on the Fuze, format it and make sure it’s in the correct USB mode when I do the transfer. But I’d really REALLY rather not to do that. If anyone can help me find an alternate solution I’d be most appreciative.

Message Edited by LockDown2341 on 05-02-2010 01:30 PM

What is annoying to those trying to help is when the questioner steadfastly refuses to give more info, and refuses to try suggestions given to him, yet keeps asking the same question over and over again.

Have you actually tried using Windows Explorer via MTP? Does it show the Fuze or no? If yes, can you click its icon and see the files, yes or no? If yes, can you drag-drop the files, yes or no? If no, what is the error message you get?

Likewise, have you tried transferring the files back via WMP, yes or no? What steps did you take, and what error messages did you get?

Even though the message seems to have been deleted, I did see another reply stating I’m basically just asking the same question over and over again and I’m not giving any more information. Well I don’t really know what more information I can give.

 

You can’t transfer songs back to the PC using WMP. I tried and I saw it mentioned in another post on here looking for an answer.

 

If the the Fuze is in MSC mode, I can see it in Explorer and access the music folder, but not the songs. If it’s in MTP mode, I can access the music in WMP but not through Explorer. Again, this all confuses me as I know I used simple drag and drop to get the songs onto it originally.

I have one possible solution for you, although I can’t garuntee it will be any help. Connect the device via MTP. Go into My Computer. At the top of the window, there should be an address bar (If there isn’t one, right-click on the top of the window, and click/check “address bar”. You may need to click/ UN check the “lock the tool bars” function, and drag the address bar so that you can see it. You may remove the address bar after you are done with this process, if you so choose). Click the address bar and type Sansa Fuze and type the capacity of your player (example: “Sansa Fuze 2gb” “Sansa Fuze 4gb”, “Sansa Fuze 8gb”, ect.) and press enter. Hopefully, this will open your Fuze in explorer, and allow you to copy all of your files from your fuze onto your Harddrive.

If that doesn’t work, try disconnecting the device, and re-connecting it in MSC. You might be able to recover your files using a similar method to the one I described above, except for the fact that you will have to type the drive letter of your device, instead of the name (example: instead of “Sansa Fuze 4gb”, you will use something like “D:”.).

I hope something in here helps.

Message Edited by halonachos117 on 05-02-2010 02:22 PM

This is really a wild guess, so it may be irrelevant.

But…what version of WMP is on the reloaded computer? If you installed XP, the WMP version with that is WMP 9, and the Sansa wants 10 or above. Go to WMP/Help and look at the version number, or Check for Updates. And if it was WMP 9, then maybe WMP 10 will be a little more cooperative. 


Also guessing, but it seems pretty likely that the unit was in Auto Detect when you were drag-and-dropping, so you were drag-and-dropping via MTP, even without WMP open. 

Did you see a little Fuze icon in Explorer when you were drag-and-dropping? That’s what you get with MTP.

If you do end up having to do it all over again, put the unit into MSC before you start. 

Message Edited by Black-Rectangle on 05-02-2010 03:01 PM

I do appreciate the help from everyone. I did try the solution with simply typing “Sansa Fuze 4GB” into Explorer but that did not work unfortunately. And yes, I do believe the player was in Auto-Detect originally, so I probably was dragging and dropping in MTP mode.

But good and odd news. Even in MTP mode, if I connect it to my laptop computer I’m able to drag and drop anyway. So I’m going to do a simple copy and past onto my hard drive, format the player and put it in MSC mode and put everything back on.

It worked! Something so simple. Oh well. Thanks to everyone who helped!

Auto Detect is the default setting for USB mode, chosen because it gives the greatest odds of establishing a connection on a new installation.  If the computer has MTP capability, meaning that Windows Media Player 10 or later is installed, integration with the device has the greatest chances of success.

Once you decide upon a communications mode that works best for your needs, manually select MSC or MTP mode on the player.  Remember, Windows does have that goofy “wall” between the modes, making files appear to be “missing”.  Simply stated, manually selecting the desired mode makes it simpler to locate all of your files.

I have seen occasional issues with transferring with the Sansa in MTP mode, it’s more prevalent with Windows Media Player 12 (integrated with Windows 7).  The simplest solution in this case is to use Windows Explorer, and use the “copy” and “paste” functions via a right-click, rather than drag-and-drop, if the files cannot be transferred.

MTP mode simplifies integration, meaning that playlists, album art, and song ratings will transfer between WiMP and your Sansa easily.  It also allows the transfer of DRM encoded (protected) media, if this is your source.

Bob  :smileyvery-happy: