SecureAccess 2.0 error

When I am copying files to a SecureAccess 2.0 vault on my 128GB Extreme, it goes along fine for a bit and then I get a popup error which says: Cannot open file for write F:\SandiskSecureAccess Vault{…}.dat Error:The directory or file cannot be created. When I click OK, the copy process stops and it ends. I have tried reinstalling SecureAccess 2.0 after deleting everything. I have formatted the flash drive as FAT32 and reinstalled SecureAccess but none of this has helped. Any ideas? Thanks.

:smiley:   Hi Sarmadi,

Dear member of SanDisk Community, welcome.

I need more data to opine:
1- As you gave format the UFD 128GB Extreme, with Fat32, please, look in Properties the UFD, and tell me:

What capacity, are there?
2- Testing, any file, with to copy and paste, and then delete, at the root of a UFD.
3- Testing, the UFD, in other PCs.

Luck, and then you tell us, what happened, please.

Regards, Alfred.                                                             (Google translated)

I am having the exact same problem.

SanDisk 128GB Extreme Pro using SanDisk SecureAccess V2.0.

Was working fine for the first two weeks, but now I get the following error when coping files into MyVault.

"Cannot open file for write D:\SanDiskSecureAccess Vault{4ce1b97b-a5a7-4457-9898-cc0390604b44}.dat

Error: The directory or file cannot be created"

Properties (general tab)

Type: Removablke Disk

Filesystem: FAT32

Capacity: 128,004,390,912 bytes   119GB

Used space: 4,914,741,248 bytes  4.57GB

Free space: 123,089,649,664 bytes   114GB

:smiley:   Hi Brishep001,

Dear member of SanDisk Community, welcome.

Thanks for your message, so concise and clear.

I assume then, you did what I advised in my reply to the previous message.
Then, we know that your UFD, has no, the error “write protected”.

1-   Please, verify that the folder: SanDiskSecureAccess Vault, not have the attribute "read only" (you look at folder Properties).
2** -  You can also download, on the UFD, another SecureAccessV2_win, and try again.
3** -
  See link:

Luck, and then you tell us , what happened, please.

Regards, Alfred.                                                             (Google translated)


:smiley:      Hi Brishep001,

Estimado miembro de la Comunidad SanDisk, bienvenido.


Gracias por tu mensaje, tan conciso y claro.

Asumo entonces, que hiciste, lo que aconsejé, en mi respuesta al mensaje anterior.
Luego, sabemos que tu UFD, no tiene, el error de “escritura protegida”.

1-  Por favor, verificar, que la carpeta: SanDiskSecureAccess Vault, _no tenga el atributo de “sólo lectura” _ (te fijas en Propiedades de la carpeta).
2-  También, puedes descargar, en la UFD, otro SecureAccessV2_win, y probar de nuevo.
3-  Ver link:


Suerte, y luego nos cuentas, qué pasó, por favor.

Saludos, Alfred.

Hi Scan Disk,


Having problems with sureAccess. Installed mac version from web site fine, everything working as per planned. But when i started transfering files into program it starts copying and in about 5 seconds the program crashes and closes. please Help!!! 

Respectfully, I tried this.  Every time you unselect Read-Only, the vault reverts to Read-Only.  This software is awful.  Is there another software solution that works for USB drive encryption?

:smiley:   Hi  Krleitch,

Dear member of SanDisk Community, welcome.

Friend, I can not recommend to the competition, from here, you understand me? It would not be correct.

But I say, that the latest version is a good software, and it works great.

Perhaps, for which you are not accustomed to using a software, can seem like a problem, but then also have problems with other softwares, that are on Internet (…and without help desk).

Therefore I prepared an instructive, in function on the questions that I see in the messages of users.

Please, try again in a “clean” pendrive. Thanks.

Remember, that there are two softwares, one for Windows and one for Mac.

SanDiskSecureAccess software is supported by Windows XP, Windows Vista, Windows 7, Windows 8, and Mac OS 10.5 and up.

Use with a Mac requires other software download.

And to SanDiskSecureAccess Software (portable app, free), you must install in the UFD.

The latest version of SanDiskSecureAccessV2 , you can download (free) from here:  


1-     Download on the UFD_,_ to SanDiskSecureAccessV2_win , (if you have PC).

Beware 1: If you see thus: SanDiskSecureAccessV2_win.exe, go Tools/Folder Options, tab View, and mark: hide file extensions, and also mark the choices: hide files protected, and not show hide files protected of the system.

2-      Then, you install the program, password, etc.

          And you will have two files:

2.1-    SanDiskSecureAccessV2_ win , (the application).
2.2-    SanDiskSecureAccess Vault , (which is the folder that contains the encrypted files).

2.3-    If you lose or delete to SanDiskSecureAccessV2_win (2.1), there is no problem, as download other, and ready.
2.4-    But if you lose or delete, to SanDiskSecureAccess Vault (2.2), you lost all content.

2.5-    You can rename to the application (2.1).
2.6-    You can not rename to the folder / Vault (2.2).
          Because the name, is generated by the application (2.1), and if you change it, the application will not open, and will generate a new Vault.

2.7-   You can move to the application (2.1), to any folder.
2.8-    You can not move the folder / Vault (2.2).
          You the should leave it in the root of the UFD, because is where the application (2.1), the will search.

2.9-   To extract the file outside from My Vault, to a folder, select and click right in the file which is inside of My Vault.

           In the menu click the left button in to “save file to” and in the new menu choose new folder, and then button “to save”.

2.10- There is an option (in the toolbar My Vault), _ which generates a Backup _ (for SandiskSecureAccess Vault), to your PC.

           And this backup, it works also, if is corrupted or erased the Vault , or is lost your pendrive.

           Ie, it works also with another pendrive, but with the same password.

Beware 2: Always make, backup content, copy the Vault, clone the UFD, etc., and save everything in “safe place”.


Regards, Alfred.                                                             (Google translated)

Alfred - I have the exact same issue.

I followed through the steps you outlined but here’s the issue:

  1. When copying files from a separate drive onto the SanDisk UFD, the “cannot open file for write…” error (that others noted) pops up.

  2. So, I go back to the “SanDiskSecureAccessV2.0” folder and right click it to uncheck the “Read Only” option

  3. I restart copying the files onto SanDisk UFD through the vault. However, in a few seconds I get the above error again.

  4. It seems the app automatically makes the “SanDiskSecureAccessV2.0” folder read only.

This is really frustrating and I am considering to return the drive if the issue is not fixed.

Please help!


:smiley:   Hi STC,

Dear member of SanDisk Community, welcome.

Please, do not grieve more, friend.

1-  Delete all content of the pendrive and after extract it, and then plug it again.

2-   To rule out that the pendrive is not failed, copy any file and see if it works well.

      Then you delete the file and see in “Properties” of the pendrive, that capacity show and that format has.

3-    If the pendrive malfunctions, try it on another PC.

       If still bad, return it, and ready.

4-    If the pendrive works well, then if you want SecureAccess, you start again with the instructive of the message # 6.

Luck, and then you tell us, what happened, please.

Regards, Alfred.                                                             (Google translated)

Hi there,

Have you found a solution for this problem? I have exact the same problem.

It used to work and all of a sudden I get the error message that the files cannot be written. Changing the mode to not read only doesnt help, it automatically goes right back to Read only.

Many thanks,



When I go directly to the USB drive I can make new folders and new files. But from the Sandisksecureaccesv2.0 I’m getting the message…

Thanks Bea

this software does not work out of the box?  

You buy it, then have to waste two hours trying to get it to work?

I begin to think it better to return it, and forget SanDisk.

1 Like


I have the same issue as Bea. SecureAccess workded very well since I had bought the USB drive in August 2014. About three weeks ago I was no longer able to add files to the SecureAccess vault.

As others have mentioned before I can add files to the USB drive if I do not use SecureAccess.

Thank you for your help.



I see many people (including myself) facing this problem and apparently, Sandisk’s support has not identified its source. So, let me provide you with an explanation that most likely will solve 95% of the issues reported here.

The problem you are facing is very likely related to the limitations of FAT32 formatting. I suspect that the customers facing this problem have many files in folders, subfolders etc. and this is why SanDiskSecureAccess is stopped at some point due to the FAT32 limitations.

What you need to do:

1°) backup all the files from your SanDisk drive (non-encrypted folders, SanDisk softwares and folders) onto antoher disk.

2°) format your SanDisk drive in exFAT, which will remove these limitations. NOTE: you will lose your Vault and all content. Do it only after proper backup. (If you are unsure: just check what exFAT is on Wikipedia for instance, you’ll see that I’m recommending here a safe upgrade).
3°) put your content back on the SanDIsk drive.
4°) create a new Vault with SanDiskSecureAccess.

Then, it should work, even if you have many many folders and files.


Thank you, Serendipe!

Your solution works perfect! I was looking in many, many German sites, but could’nt find help for this problem. But now I’m happy! The problem was only FAT32! Thanks a lot!


Wouldn’t NTFS work as well?  Or is the software locked into the FAT32/exFAT system?  I don’t need to have the drive accessible to a Mac computer.

SanDiskSecure Access puts all the files for a vault into a single directory regardless of the directory structure it shows on screen. This can be seen by using File Explorer.

If using FAT32 when you try to put over 13,000 files into a SanDisk Access vault you will get this error.

Possible solutions either upgrade to a newer file structure (eg exFAT, NTFS) or create multiple SanDisk Access vaults.

SanDiskSecure Access puts all the files for a vault into a single directory regardless of the directory structure it shows on screen. This can be seen by using File Explorer.

If using FAT32 when you try to put over 13,000 files into a SanDisk Access vault you will get this error.

Possible solution upgrade to a newer file structure (eg exFAT, NTFS)  Create multiple SanDisk Access vaults does not work as the file limit applies across vaults.

I registered with this forum because Serendipe is awesome and after those flowery but useless responses from a Sandisk so-and-so, it was refreshing to see a useful and correct response.

Thank you Serendipe!

SecureAccess 3.0 is a fully redesigned password protection and data encryption application which uses a new encryption engine. … Launch SecureAccess V2 and copy all the data from the Vault to your computer hard drive or another flash drive. Delete the SecureAccess V2 Vault and Application files.