SansaFuze wont turn on when plugged into the USB port.

Hi.My SansaFuze wont turn on when I plug it into my USB port and I dont know why.It worked on Saturday but wont work again.Any help?

Try resetting the Sansa Fuze first. See if that helps.

By reseting,do you mean restore it to it’s factory settings?

Clicking on the resetting word in red and underlined should have provided the steps but, here it is just in case :smileyvery-happy::

Resetting the player:

  1. Slide and hold the Power switch up for approximately 20 seconds.
  2. Release the Power switch.
  3. To turn the player on, slide the Power switch up then release instantly.

I did that.And nothing happened.

After resetting the device did you power it back on? What happens if you plug it on your computer? If you are using a desktop computer, try plugging at the back USB port for sufficient power to be supplied to the device.

Or do Force MSC:

  1. Turn device OFF.
  2. Slide the Hold switch down to Lock (orange color showing).
  3. Press and hold the left button ( |<< ) while connecting the device to the PC.

See if this helps. If still, theres no response on your Sansa, then its most likely to have died on you. Possibly the battery got loose or something. If so, check warranty by contacting SanDisk.

Thanks dude.I never knew about the back USB ports.You sir,are my hero.I can put music on my thing again.Thank you so much.:wink:

Glad that worked for you. Seems like your front USB port does not supply sufficient power.

You’re welcome! :smileyvery-happy: