Sansa Fuze+ - will not turn on


Been using the product for last 2 months now.

Purchased it in the US while on a trip.

Was working well until I charged the unit over night using the USB cable. the next day morning I just pulled out the USB cable and since then the Fuze+ will not start or turn on.

I have approached the sandisk support and have tried hard reset and connecting in MSC mode but with no success.

if someone faced a similar issue and it was resolved, please let me know.

I’m having the same problem, I’ve tried everything possible, and it still doesn’t work. I may have to return it.

Depress and hold the power button for 30 seconds, release, then try powering up normally once again.  This will reset the Fuze+.

Next thing to check is trying from the PC side.  Plug in the USB cable and see if after a few seconds the display wakes up with the familiar USB icon.

If the player is frozen, it may not recognize the USB connection, and will not respond.  In this case, disconnect, and try the soft reset once again.  (USB connection is also handled by the Fuze+'s processor).

I have seen the device freeze requiring a reset like this.  Compared against the earlier device, the delay before the display wakes up can be a little longer, about 8 seconds or so.  The earlier machines would most often respond to the USB in 3-5 seconds.

If the device does not respond, starting with the device OFF, you can try holding the Volume Down button while connecting, and give it a few seconds to be recognized.  This is how we can manually force an MSC connection, allowing you to cheak the drive for errors or reinstall the firmware, if need be.

If the above method does not work, contact Support at 1-866-SanDisk for further assistance in the US, or click on the red SanDisk logo in the upper left of this page, then click on Support for contact information.

Bob  :smileyvery-happy:

I was listening to my Sansa Fuze + when all of a sudden the track froze and a loud buzzing noise came on.  It wouldn’t turn off and my computer didn’t recognize it when I plugged it in with the USB cable.  After reading someone’s advice from your site, I realized that by holding the on/off switch for 30 secs or so, the device would reset itself.  Well, it did.  After holding the on/off switch for about 15 seconds, the screen went black.  I then plugged in the USB cable and now it’s connected and looks like it normally would.  Thanks for your forum.  Now at least I know that I can reset it in a crisis.