Fuze+ won't turn on (unless...)


A few weeks ago my USB cable for the Fuze+ got damaged, so I couldn’t charge the player anymore. I used the player until the battery ran out. Now I got a new cable and tried to charge the player again (connecting it to two different computers, and also to a power outlet via a USB-to-power converter), but it wouldn’t charge or turn on. I tried soft reset (via the power button) and it didn’t work, but then the strangest thing did - I pressed both the play/pause button and the down part of the touch pad, and it came on and started charging! But only right until the point where I released one of the buttons (even slightly) and then it turned off again. And even this didn’t work every time.

So I’m trying to understand - is this a circuit problem and me pressing fixed it for as long as I was pressing, or is the player in the middle of some weird undocumented reset procedure?

Thanks a lot in advance.

Once the Fuze+ gives you the “connected” logo on the screen, following a completely discharged battery, allow it to charge for a few hours first.  The Fuze+ will automatically halt the charging operation once full, so I’d recommend leaving it plugged in overnight.

The device should then resume normal operation.

If there are any quirks to powering up, the soft reset is key: press and hold the power button for about 20 seconds, release, then try powering up normally.

I recommend updating the Fuze+ firmware to the latest build,it’s much better.  Please note that the LOCK function will be changed to a single (about 1 second) press of the power button.  To lock / unlock, everything is redirected to this button, as opposed to the old “swipe” method.  You can update the firmware using the Sansa Updater, or follow the manual installation directions in the Fuze+ Firmware thread.

Bob  :smileyvery-happy: