Charging problems

I bought a sansa fuze+ and it wont turn on. I plugged it in to 3 different computers, and none of them will charge it. I tried holding the power button for 30secs and that didn’t work. The device says that its connected, but the icon on the computer says that power is at 0% and its been plugged on for several hours. I can get music on the device, but it wont turn on so I can play it and the power is so low that the firmware wont update. Please, if anyone can help, I would be grateful

Try a wall or car charger.  Also give it time (5 to 10 minutes) when it is connected to a computer. 

Sounds like your player may have hung up- try holding the power button depressed for 30 seconds, then release.  See if it will then start normally.

If you are trying to connect to a PC, perhaps MSC mode will be your option.  If the device is trying to establish communications, it will not charge properly.

Here’s the process to force MSC mode on your player:

Sansa Fuze+

  1. Turn device OFF.
  2. Press and hold Volume Down button.
  3. Connect device to PC while holding Volume Down button.
  4. Once the Fuze+ connects in MSC mode release Volume Down button.

Bob :stuck_out_tongue:

Just purchased a Sansa Fuse+ 16G, When I plug into the USB screen indicates connected. It will be OK for 1 minute or so, then the screen goes dark and I loose the USB port (Fuse icone gone from media player). If I pull the cable & wait 20 sec or so, then reconect, the Fuse+ comes back to life. I have bone the firmware upgrade but it did not fix the problem. Some one on another page said to try holding the Volume down, it did not work. I am trying to set the SLEEP & powersaver to 120 minutes. It lasted 3 minutes then went down. 

Anyone have any ideas?

Maintman, my fuze+ are doing exactly the same tha yours! I can’t charge it.

If you find a solution, please let me know. If I found one, I will post here.


Solved, there was a cable problem, maybe bad quality. The cable is able to charge the fuze when it is partially charged but not when the battery is completely discharged, I changed the cable with another of good quality and the fuze+ are charging whitout shutting down.

I’m having a similar problem. My Fuze+ has been charging for the better part of 6 hours now, but the only screen it displays says “Connected” and every time I take it off the cord the screen goes completely blank. The battery icon appears to indicate a full charge, but like I said I can’t take the player off the cord.

I’ve updated the firmware and tried pressing the on-off switch for everything from .5 seconds to upwards of 2 minutes. I’ve also tried the volume button trick someone mentioned earlier, but so far I haven’t had any luck. What other options do I have?

If there is a problem with your battery, the Fuze+ will discontinue charging, as in the case of a failed battery.

Symptoms of this condition are a “Critically Low” message when plugging in to a Windows 7 PC (device stage view), and you will see a full green battery indicator on the Fuze+ when plugged in, with a lightning bolt icon at the center of the battery icon.  Confirmation of a failed battery will be if the Fuze+ immediately goes blank upon disconnect, and will not power up.

In this case, I’m afraid it’s a bad battery (the charge indicator does not “roll” while plugged in).  Contact SanDisk Support at 1-866-SANDISK for warranty assistance.

Bob  :wink:

If the computer is desktop then use a port in the back, not the front. Front ports may not provide enough power.

Are you saying that if when connected the battery indicator is green and a lightnign bolt shows, that it means the battery is bad?

I assumed that meant the battery was fully charged, as that is the only indicator I have had from new.  When plugged into the computer the green scrolling on the battery indicator has taken place for hours, followed eventually by the lightning bolt.

Hopefully I can get a replacement if the battery is defective, I haven’t used it that much (maybe 25 times) since I bought it in July.

No, the lightning bolt only signifies charging operation completed.   If you have a bad battery, the Fuze+ will signify that it is either fully charged, or if the charge operation is not possible, the bolt shows that the device isn’t going to do any more charging.

By happenstance, I have a brand new device here with a bad battery; it goes black as soon as it is unplugged.  Refreshing the device, it displays (Windows 7) as “critically low”.  Sad, but it happens.  I really like the white case too…

Bob  :cry:

@pdumas7 wrote:

Try a wall or car charger.  Also give it time (5 to 10 minutes) when it is connected to a computer. 

I had made this statement earlier.  I have found that the was charger that came with my Blue Tooth device will keep the screen on but not charge my Fuse+.  This charger is just strong enough for a very small device.  

If unit shows full charged and  still will hot stay on, I would try resetting it while it is connected.  This is not something I have experienced. 

When it’s plugged into the computer it has been charging and getting the lightning bolt, but goes off when I unplug it.

I tried it with a wall charger earlier, but it kept powering on, showing the “flower” symbol, then a large battery symbol with a red bar, and it would intermittently go off again.

I just got it to connect on the desktop again, right clicked on the properties, and it shows Battery Charge = 0%.  Not good!

Now it’s off again, just powers on for a few mins, then goes off for a while.  I did try other USB ports as well but no difference.

Guess it’s time to look at seeing if I can get it replaced.  Shame, it’s not a perfect MP3 player, but good enough for the price, and it doesn’t require iTunes, which is the bigest plus!

My fuze+ 16gb just arrived yesterday, and guess what!?  

Won’t charge…

I’ve tried every suggestion in these forums using Multiple USB ports of 3 different computers, plus trying with a AC adapter.  

Nothing works =[

I hear updating the firmware might help?  But that’s now doable when you have less than a 50% charge. (currently at 14% - was 48% when I took it out of the packacge and hooked it up, initially - it has less and less power after each charging attempt)

I guess it’s time to contact the returns department.