The fuze wont charge

My friggin fuze wont charge.

its pretty low.

It keeps disconnecting itself after a certain amount of time.

I tried the front and the back.

My fuse will start up then say

'Battery is too low

System shutdown’

I just got this for Christmas.

It was working fine until now.

Help? :slight_smile:

Did you try to reset the fuze? Push the on button up and hold it for 15-20 seconds. Then Try to plug it in. See if that helps? Are you using a Desktop PC or a laptop to try to charge?

I am using a PC, and I’ll try resetting it.

I am a newbie. so

if i reset it I still have my music there right. O.o

sorry for being so dippy,

YOU WILL HAVE YOUR MUSIC! it basically resets the fuzes internal gizmos and programs, noting else. And I wouldnt call you dippy unless you were a guru asking that question.


:l it didnt work.

When you plug in to the computer does it recognize the fuze as device. Plug it in to the computer and go to my computer and see if its there. Also did you update the firmwire?

I did both.

Its not there.

Ive been switching the charger between 4 different ports in the back, its gotten to the point where I can turn it on and it wont say something about the powerless and having to turn it off.

Thats about it tho.

Try doing this, it worked for me


@neutron_bob wrote:

You can try charging it up first, by connecting in MSC mode manually.  This way, you can start with a charged Fuze.


  1. Open a Windows Explorer window by pressing the [Windows key] + E, or go to My Computer.


  1. Starting with the Fuze OFF, slide the power switch to the HOLD position (orange showing).  Press and hold the center button down while connecting to the USB port.  You should hear the familiar ba-ding sound as the device is recognized, and it should show up on the screen.  At this point, release the button.


This will allow the Fuze to charge: have a look at the battery icon.  It should be strobing.  Connecting in MSC mode is an easier task for the Fuze.  In this mode, it’s seen as a flash drive.  I suspect that the MTP mode might be your problem.


When the Fuze cannot establish a connection, it can get distracted from the charging operation.  It’s best to charge it before working on the MTP part of the equation.  Once it’s charging, you can slide the HOLD switch back to the center position.


Bob  :stuck_out_tongue:

THANKYOU! It worked.

thanks heaps,


Thank you, it just worked for me.

fyi: the accepted solution wouldn’t work for me as my fuze battery was too low to do anything with it, so…

The main problem I was having was that it would not charge via USB

This worked for me:


  • started having similar problems with my Sansa Fuze 4GB
  • main issue: would not charge via usb connection
  • my OS is: winXP sp2
  • I had turned off (i.e. changed to ‘manual’ start) a service named “Windows Driver Foundation - User-mode Driver Framework” (prog is: WudfHost.exe)


  • restarted the service and *presto* it immediately started charging again

* be sure to change service ‘start’ to “automatic”

…If someone else wouldn’t mind, please explain start/stop services for those that don’t know.

THX and Good Luck!

Thanks so much Bon that finally worked for me

thanks for the info!!! I dont let battery getting low another time!!


@rachel_rawr wrote:

THANKYOU! It worked.

thanks heaps,


@rachel_rawr wrote:

THANKYOU! It worked.

thanks heaps,


Call 1-866-SANDISK and arrange for a replacement. You have a one-year warranty and you shouldn’t have this problem with a month-old unit.