Sansa Fuze + MP3 Player Won't turn on

I just purchased a SanDisk Sansa Fuze + MP3 Player, 8G. I know that you are supposed to charge them fully when you first get them, so I plugged it into my computer right away. My computer recognizes it, the screen lights up and shows the word “charging” with the USB picture, and the battery is green with a little white lightening bolt. My computer instantly installed the drivers and I installed the firmware updater from the SanDisk website. Anyway, they suggest 3 hours to charge, so I left it charging for that amount of time. However, once I unhook it from my computer…it won’t even turn on. We are talking zero power.

So I plugged it in again to my computer, and the device has this little pop-up that tells me the battery is at 0% still. Okay. So I keep it plugged in for another 3 hours, and then pull out the USB and try to turn it on. Nothing.

I am at a complete loss. When I plug it back in, it tells me the battery is STILL at 0%, After 6 hours of charging.

I have a brand new HP computer, so I know my USB ports are fine. It lights up and says charging, so I know my computer recognizes it. Yet, it will not turn on.

Any ideas for what could be happening? I would be most grateful!


Received Sansa Fuze+ 8 GB as gift today.  Device was dead, so I plugged it into my desktop computer to charge.  Device was not detected.  Tried same on my laptop.  Device not detected.  Tried software update - won’t download to either computer.  The disk that comes with it wants me to go buy stuff at Rhapsody.  I think this gift is a mistake…  I don’t need a paper weight. 

Yea,  I am  just taking it back tomorrow. I have now tried it on all 4 computers in the house, three of which are brand new. I tried it in every single USB port and nothing. It still reconizes the player and the screen lights up and says charging, but sits at a 0% battery.

What a waste of money and time. I’m sad that my mom opened this gift this morning and it didn’t even work.

Have you tried resetting it? Press & hold your power button for 20 - 30 seconds. Release, then see if it will start up normally.

Yea, I tried. But with 0% battery, it didn’t do anything. There was absolutely no power to it. I have already taken it back and purchased another product.

I believe that you can have this thing replaced by sandisk if there is a hardware problem, which I think you are experiencing. I think that would be your best bet.