Sansa Fuze+ fully charged but not turning on!

I have a problem. Whenever I plug my Fuze+ in to my computer it says connected showing the USB cable image and in the top right it shows that the battery is fully green, now I assume that means fully charged. So I unplug it, press the power button, and it doesn’t turn on! Please help me!? I don’t know what to do!

Have you tried resetting it? Press and hold the power button for 20-30 seconds. Release, and press it briefly and see if it starts up normally.

I have tried that multiple times, I’m about to assume it’s just gone forever.

I wouldn’t assume that just yet. Try leaving it on to charge for a full day or two. I’m not sure why this works, but apparently it has for others with similar situations not only with the Fuze+ but other SanDisk players as well.

If not, is it still under warranty?

I have left it to charge for four hours before, I guess I could let it charge for a day or two. It’s probably not under warranty, I got it on Christmas of 2010.

Yeah, I’ve had it in for a day and still nothing.

See if you can locate a basic source of power, either a USB wall charger, a mobile phone charger (with the microUSB connection), or even a powered USB hub, with all other USB cables disconnected (except the AC adaptor plugged in for juice.

With this power source, see if the device turns on.  Since it does boot up, showing the “connected” icon, it should operate when plugged in to power only.  If it runs OK with the “umbilical cord” connected, the internal battery may be the issue.

Bob  :wink:

Yeah, I may have dropped it one too many times, whatever, my parents said I might be getting an iPod for my birthday. It’s not a big deal if I can’t get it to work, I’ll try that though.

Liamnator wrote:

Yeah, I may have dropped it one too many times, whatever


_ Really?!? _ :dizzy_face:

If I were your parents, you’d be working to buy your next one yourself! :angry:

I dunno, I haven’t used it since before or during summer of '11. I don’t even know if I dropped it and it broke or not, nothing is cracked, it’s prefectly fine on the outside. I’ve done a lot of chores too, like I spent $300+ on my longboard last year, and buy this time, I’ll have at least $100 + money from my birthday :3

Ours did this brand new!

Would not charge on 3 different computer USB’s

Connected to a USB charger only and it worked fine,now it charges at the computer also:smileyvery-happy:

I may just put the player back into the package and take it back to the store.  This thing is JUNK!     I don’t know why things like this don’t seem to work right.   I am going to call technical support up and tell them that this junk needs another make over.   Maybe the battery could be defective. 

You are not alone, this happenned to me too.   I feel this is a major defect and someone needs to look into it.  I will forward this to technical support.   And off goes this player back to the store!