New Fuze+ won't turn on


I bought 3 fuze+ players for my children. 2 of the 3 started up just fine with no errors. But 1 of them is giving me problems.

When initially opened, it would not turn on. It was plugged in to charge. After having a full charge it still would not come on. It did allow the firmware to be updated. I have tried doing a soft reset will no luck. Any ideas on what else to do would be appreciated…


Received Sansa Fuze+ 8 GB as gift today.  Device was dead, so I plugged it into my desktop computer to charge.  Device was not detected.  Tried same on my laptop.  Device not detected.  Tried software update - won’t download to either computer.  The disk that comes with it wants me to go buy stuff at Rhapsody.  I think this gift is a mistake… 

KAustin, maybe you should try reformatting the thing. That sometimes helps with weirld errors. Hitektex, how long did you plug it in before giving up? i have found that it takes about a minute for my computer to detect my Fuze. IDK why.

KAustin, I’m sorry to hear that you have one of your Fuze+ devices that has suffered an aneurysm.  You shouldn’t have to go to great lengths to resuscitate a new device. 

It’s probably a textbook case of Murphy’s Law.  Mr. Murphy was an engineer for Hughes Aircraft, incidentally.  With electronics, I have a huge and humorous list of failures related to things electronic.  For device failures, all humor aside, if the device is going to fail, it most often will do so very early in its service life, or it will last a long time.  I recommend exchanging the troublemaker for a new machine.

SanDisk covers defects for one full year (two in Europe)  As it’s the simplest and fastest, I’d contact the retailer for an exchange- they will handle the details for you.  Beyond the initial period or guarantee, you can contact SanDisk directly for warranty service.

Bob  :wink: