Sansa Fuze + won't turn on.

I have done everything it has asked.  I have a lighting bolt in my battery in the upper right hand corner. It says it is connected.  When I disconnect I can’t turn it on though. What is the problem, I’m getting pissed and will return it and never buy another one if this ■■■■ continues.

Hold the power button down for 30 seconds.  Release.  Hold power button for 3 seconds.   Good luck.  

it turns on when i keep it plugged into a wall, and it says it has full charge, but when i unplug it, it won’t turn back on

Have you tried the holding power button 30 seconds to reset the unit?  I had to do this myslef a few hours ago.

yes, and it still won’t turn on when i unplug it from the wall. it says it has a full battery. what is msc and all that stuff. i just read that i should change it to msc

I think that stuff is about USB connection modes.  I would leave it on automatic detection.  

When you disconnect you unit the unit should stay powered on.  You will see the sandisk splash and the unit will sort.  The screen will go black.  The touch pad should work.

Be ready to try another unit.  Most products have a small percentage of defects.  

If you have wall charger you can play while connected to power.  You may get a sample of  how it works.  This will also let you test all of the buttons.  The power button will lock and unlock the touch pad.

I’ve tried everything I’ve read in these posts. I workout with my own music so I can’t just leave it plugged in. gonna return this one and try another one. But if that new one has the same problems then I’m done, what a piece of garbage. They should have stuck with the old one.

AS I’ve just said on your other post:

@halonachos117 wrote:

@typ1715 wrote:

why do companies always have to screw a good thing up…

You know, I’ve had this problem with the old Fuze before. All I had to do to fix it was reinstall the firmware. That fixed everything for me. Try plugging the device into you comp while holding the volume down button. That will force the device to emulate a USB Flash drive. Maybe that will make it connect to your computer. If not, then try reformating the device (couldn’t hurt, right? After all, it’s not like you can do much else with it). Otherwise, get a replacement.

Good luck.