Fuze+ has stopped working


First of all I’m French so my English may be poor, please excuse me for that.

So I’ve got a big problem with my Sansa Fuze+.

Since today I can’t make it work. The device doesn’t turn on. I tried the reset thing by holding the power button for 30 seconds but it doesn’t change anything. I can’t either connect it to my computer anymore.

Yesterday it worked perfectly but today I don’t uderstand what is wrong, I didn’t do something unusual.

Could someone help me? Thanks.

The processor that runs your Fuze+ also manages the connection to the computer.  If it is halted, or stuck, it’s possible that the Fuze+ will not be recognized by the computer, since the USB communication is also handled by the Fuze’s processor.

Try resetting the device again by holding the power button for at least 30 seconds.  You can then try powering up with a brief press of the power button, or leave it plugged in to the USB port for a little while, to see if the Fuze+ wakes up once again.

I have seen this, where the Fuze+ can freeze.  It is possible that a few tries may be needed.  If the device will not restart, it is covered under the original warranty (1 year US, two years EU).  Contact Support for a possible replacement ia all else is unsuccessful.

Bob  :wink:

Thanks for the reply.

Actually I tried to plug my Fuze+ into my other computer and after about 30 seconds it “woke up”. So I let the battery charge completely and now there is no problem anymore.

Thanks though.

1 Like