Sansa won't turn on :(:(:(

I don’t know what happened, just tried to use my sansa and it won’t come on at all.

Even though I knew the battery wasn’t dead from when I used it a few days ago I plugged it into the PC to charge just in case, but the PC doesn’t even recognize it.

Have tried holding the on switch to reset but it’s like the battery isn’t even there!

I don’t understand and don’t know what to do - help!

I got it from amazon, and am 2 weeks over the 30 days return policy so I don’t know if i can send it back or if they will tell me its not their problem.

Would really appreciate any advice/suggestions.

Hold the power switch in the ON position (spring) for a good 20 seconds or so.  Release the switch, then try plugging in to the USB port to charge.  If all is well, the Fuze will power up and begin charging.

Let it charge (observe the battery indicator, and be sure that the wee lightning bolt displays).

Bob  :smileyvery-happy:

I have tried a few times but nothing happens at all :frowning:

And when I plug it in to charge the sansa doesn’t show any sign of life and the Pc doesn’t have anything to say it has recognized a device. Argh :frowning:

If it does not respond, give the reset a little more time, up to 30 seconds at the most.

The Sansa can have problems if it cannot communicate with the USB port as well: if it is busy trying to establish communication, it will bypass charging.  Many have found that a USB wall adaptor works great for basic charging.

In an emergency, you can plug in the USB end slowly until just the outermost power pins connect.  Once the Fuze lights up, it will charge.  Try again on the reset and see.

Bob  :wink:

I have tried all the things you mentioned but no luck…

I found a usb wall adaptor so plugged it into the wall. The only interesting thing was that the plug has a red and a green light on it, when I connect the fuze both are lit up, but if I hold up the fuze button as if to turn it off the green light goes out - so it seems there is something going on with my fuze but the screen shows nothing, and other than that green light on the wall plug there are no signs of life.

From that is seems like there’s something wrong with the screen but just a guess :frowning:

Do you think the sandisk people will replace the screen/give me a new fuze if thats the case??

Thanks :) 

Since it’s under the basic one year warranty that comes with the fuze, call Sandisk… 1-800-SANDISK. They’re customer service is great! Well, to me it is. They won’t replace the screen, but they should replace it. They may even come up with an answer that will help all! Please tell, if there is one!

Message Edited by saxmaster765 on 07-19-2009 05:18 PM

Thank you I have contacted them (they were really helpful!) and have sent them an email with all the details so hopefully they will replace it or work out whats wrong! Thank you to everyone that gave advice :slight_smile:

i had the same problem as her but i tried your method and it worked!!! thanks!! :smileyvery-happy:

:smiley: You are a lifesaver! I’ve become quite hooked on my MP3 player for unwinding before going to sleep. The same thing happened to me–Wouldn’t turn on or connect. I did what you suggested & it’s working again.  I got my player as a Christmas Holiday gift from my DH, so it is extra special too. Thanks SO much!

Thank you. It worked. I haven’t had it very long and I was so upset. So thanks everyone for the solution

30 sec reset worked for me :slight_smile: