My sansa doesn't get charged at all

This is the first time I’m dealing with this problem. I connect it and it shows me the yellow lightening next to the battery which shows it is charging, I left it there for more than 6 hours, and then when I disconnected it, nothing changed! The battery was less then before. It used charge instead of charging it.

I tested many ways, I used the USB ports in the back of system. I read some helps and did everything. The problem is, it shows me it is charging and everything seems correct. I don’t know what else I can do. Please help me.

I had a similar problem that this forum helped me solve…maybe it’s the same one you’re having.

Try changing your USB settings (under the “System Settings” menu) to either “MSC” or “MTP” and see if that helps.


tnx Randy, but I have tried that before. it didn’t help  at all. I am losing my mind!:cry:

Do you have a USB > wall outlet adapter?  That might work.

yes, i’m testing it. i’ll let you know the results.

no it didn’t work!!!:womansad:

Man, I might be stumped on this one.  So it charged before and this is the first problems you’re having with it?  It might be that the battery indicator isn’t working and your player actually *is* charged.  Sory of like if your gas gauge was broken on your dashboard.

How old is the unit? Less than a year, it’s under warranty and you should call 1-866-SANDISK.

Other possibilities:

Something wrong with the cord. See if you can borrow one from another Fuze owner, or buy one (about $5 or less for generic). Don’t get an iPod cord, it will fry the Sansa. Sansa Fuze or E200 cord only.

Battery has gone through too many charging cycles and can’t hold a charge any more. This seems unlikely to me, since I charged and recharged the same Fuze for years.

Battery connection is bad inside the unit. That would mean a repair/replacement if it’s under warranty, and not reparable out of warranty.

It’s a gift from almost 2 years ago, and also, I can’t buy any new cable or sth like that for it. Because I’m not in USA and I didn’t see sansa fuze in our market. Obviously they don’t have their cable too!

Is it possible that problem is with my computer power supply? Should I test it in another computer?

Yeah I could charge it before, I’m doing it for almost 2 years, and I don’t know suddenly what happened that It is not charging.

I know what you mean, I’m gonna use the rest of charge to see it it will work or turn on after the battery indicator shows me there is not more charge there.

Since it is that old the battery may have come loose, which is not fixable, or it may be wearing out.

I would try another computer, and all the ports on your computer front and back–no hubs. Also, just curious–when you connect to the computer can you see the files on the computer?

The cord makes two connections–power (for charging) and data. Sometimes one connection works and the other doesn’t. But if you can see charging that would suggest the connection is being made–which means the battery itself may be the problem.

yes, I can see the files in the computer.

is it possible that problem is from my Win?

Windows is finding the files, so it probably has nothing to do with Windows.

I hate to say it, but I think it’s your battery. Either it is too old to recharge any more, or it has a bad connection. Either way, It’s probably time to look for a new music player.

I charged it with another computer and guess what? It worked!!! SO, the question is if the prob is not from my Win, so, what is the probelm now?

The USB port on your computer is not putting out enough power. I hope you are not trying to use a USB hub but are plugging the cord directly into the computer.  Try all the ports–back ones are usually stronger–and if they don’t work, then get a USB wall charger that lets you plug in the Sansa cord.