My Fuze won't charge...

[Let me preface this entire post by saying that I am SOOOO not a techie in any way!    So I will be describing my problem in the most simplistic of terms, and warn you that if you do decide to be lovely and try to help me, you’ll have to use small words, speak very slowly, and over-explain things that seem otherwise obvious!  :wink:]

I got my Sansa Fuze about six months ago, and I have been VERY pleased with it, and the Rhapsody To Go combo.

But now it won’t charge.  :cry:

I plug it up and it comes on, but the little bolt of yellow lightning :smileyvery-happy: showing that it’s charging does not appear.

Still, I was previously happy enough with the product to give my son one for Christmas.   Using the same cord and port, his charges fine.

What is wrong with mine?!:cry:

Try plugging it in to the back of your PC. Your battery may not be getting enough Voltage for it to charge. On The Sansa FAQ there are some tips for elongating battery life have you been doing these? I would suggest it.

Another simple thing you can try is to reset the player by holding the power button for approximately 10 seconds. Resetting it can resolve all manner of strange behaviors.

Thanks for the suggestions.   I tried both with no positive results.  :cry:

Soooo (dumb question here) DO the batteries eventully go out and need to be replaced…or are they supposed to last indefinitely, if used properly?

Well, no battery lasts forever. Six months is pretty short, though. It shouldn’t be dying yet.

So where would I get one, and, uh, how do I go about replacing it?

I tried to gently pry off the back cover, but it was NOT going to come off without force, and I didn’t want to bust the entire thing.   I don’t see any screws or anything?

Did you ever own a chordless Drill? The batteries on mine had a “Memory” which meant as I used it and it got weak and I recharged it, the little bit of remaining power was left on the battery and It built up until the battery was dead. I am afraid that this may happen with Fuze batteries. I dont know for sure. You may want to check with Sansa about warrantys and battery life. It would be nice if there was a place you could take it (Geek Squad) to get the work done.

Sandisk uses lithium-polymer batteries though, which supposedly aren’t subject to the memory effect that made older rechargeable batteries lose the ability to provide power all the way from “full” down to “empty”. Most cordless tools used nickel cadmium (the old, crappy type of rechargeable) batteries up until just a few years ago, and some still do.

I agree that you should contact Sandisk about the warranty, though. If you bought your Fuze new, it’s covered for 1 year.

I knew the battery wasnt supposed to remember but it was the best analogy I could draw.

One suggestion…I have heard that most of the time we should recharge after only a partial discharge, but that about once a month, run it down to about 15% before recharging…"resets the virtual fuel gauge " was how it was described to me. I don’t know your typical charging regimen, but thought this might be of help to you.

 How full does the battery gauge say it is? Do you have a wall charger you could try charging it with? Are you plugging it into a rear USB port on a desktop pc, or if you are using a notebook pc, is it plugged into AC power when you connect the player?  Are you using a notebook? If so, you should check your power saving settings.

Is this the first time it happened? Are you connecting the player directly, and not through a hub or USB extension cord?