Hi, I’m new to this, so please forgive any errors on my part. I am getting the message"USB device not recognised" when I plug my c140 into my computer, I have done all the checks and uninstalled and reinstalled and still no joy, I would appreciate any ideas on wot to do next? 


Do you have Windows Media Player 10 or higher installed?

I imagine if its the same thing everywhere, and it has never worked before then it is probably a defective player. Maybe give sandisk a call @ 866.sandisk

thanx for answering…yes I changed to mp 10. I have also been in contact via email to sansa re problem and are awaiting their reply.

Regards MD 

thanx for answering, I have contacted sandisk people via email and am awaiting their reply, could take 3 days! according to their automatic reply.

regards MD

hi all am very very frustrated. had bought this mp3 player on ebay and did nt get the software that its suppose to have. went to the sandisk website and well that was NOT a help at all. is there a link that I can go and get the software needed to up and down load music and such?

Hi, sorry to hear u have bought a sandisk, i hope u have better luck than me i’m still trying to resolve the problem. here is their e mail address   phone 866 sandisk or 18007930652 est. i hope this helps


You don’t need any of the software that comes on the cd.

The onyl thing that is there that you MIGHT find useful is the users guide. Which can also be found in the general information page of the c100.