Sansa wont turn on

Hi, I purchased my 2 gb FM radio clip about two months ago. It worked fine until now. My clip wakes up if I connect it to my laptop and it charges and I’m able to edit music etc… But as soon as I unplug my clip, the screen goes black and I can’t turn it on. I’ve tried holding the power slide for 15 secs and then try normally power on but to no result. It seems that the only way to get any response from my clip is to plug it to a computer but it justs shuts itself down immediately after unplugging. what can i do to fix that???

Why don’t you try reapplying the firmware and see if that helps–perhaps something corrupted the files.  (See the firmware sticky thread at the top of the forum, to download the firmware.)

I have this same problem (1gb) and I downloaded the firmware, but I can’t turn on my clip to get it to settings to get it into MSC mode. When I plug it in it will not let me go into menu, it just tells me it’s connected and flashes the logo. As soon as it’s unplugged from the PC it goes dead. If I try to turn it on several times, once in a while it comes on for a second and goes to the music logo (w/ headphones) and then shuts off.

Any way to update firmware without turning unit on?

If you don’t currently have the most recent firmware installed, you could try installing the Sansa Updater and then connect your Clip, and then hope that the Updater connects up and updates your Clip.

edit:  Or, if your Clip will connect up to your computer, can’t you update your firmware manually (see the sticky thread at the top of the forum)?  Possibly, also try a reset, if that might work (Clip’s on switch in the uppermost position for 15+ seconds)?

Message Edited by Miikerman on 07-10-2008 07:34 PM