Sansa Fuze won't turn on all the way

Seems I have a weird problem. Started just today. My Sansa is stuck!!

Whenever I turn it on, I get the moving Sansa word, then the symbol, then after that the screen flashes completely white and blank for about 1 second.

And then, instead of taking me to the menu, it goes to this again. (shown in image)

And it stays frozen like ^ that and does nothing unless I hold down the sliding “on” switch for several seconds. Then it shuts off.

And does the exact same thing the next time I turn it on again every time. No Menu, no response, my computer won’t detect it so I can’t even format it.

The last thing I did before this happened was attempt to update my tracks on Rhapsody. It kept telling me to connect to my computer to update them, so I did, just like I always do. I even made sure to safely remove it. But this still happened. I’m at a loss.

Any suggestions would be much appreciated.



Connect the player to your pc. Make sure all of the songs on your player are also on your pc hard drive, then format the player deleting all the songs on it. Disconnect the player and see if it starts up properly when empty. If so, then the problem is with your files. If the problem is with your files, load the player except for the songs you had added recently, after the problem started. See if it works fine. Examine the files you added most recently before the problem started. Run CHKDSK on the copy of your songs on your pc.  My guess is that the problem probably was that you put some corrupted files on the player.

Nothing happens when I plug it in. It just does the same thing and freezes at the startup. I’ve tried on 2 different computers, neither will detect my player. :cry:

Have you tried holding down the left button while connecting it to a pc?

Just tried it a few times, same thing happens, it won’t respond.

You tried holding the power slider in the up position for at least 30 seconds to reset it, then let go of then button then tried turning it on?

Try pusing the power slider all the way down to the locked position, then hold the center button down while connecting to the pc. seeif this will get it to connect.

This is from the Rockbox page about how to un-brick a Fuze. Worth a try.

Formatting a Player that cannot get past the Database Refresh in the OF

If you damage the filesystem on the internal SD you can find yourself in a situation where the database refresh in the OF hangs up and you will be unable to boot into the OF and also unable to connect via usb to correct the problem. If you find yourself in this situation you can bypass the OF database refresh by connecting your player via usb and disconnecting it just after the Sandisk logo appears on the screen. This will bring you into the normal top menu in the OF and you can then format your player through the settings menu.

Thanks everyone for the suggestions, really, you guys are awesome for helping! :slight_smile:

@ JK98, I tried everything you suggested in detail, multiple times. It didn’t work unfortunately.

@ Black-Rectangle, thank you so much. I tried exactly what you said, and instead of not responding, it flipped out, and began to restart over and over just sort of flipping on and off playing the turn on and the logo repeatedly.

I think my player is toast… My dad was looking for a new one anyway and said I could have his. So it’s not a total loss.

I’m stil not sure you have gotten exact directions about forcing a computer connection.

Leave the unit off.

Push the power switch Down  to click into Hold position (orange dot in the slot).

Connect the USB cord end to the computer.  Open Windows Explorer (Computer or My Computer).

Hold down the << side of the wheel. Connect the Fuze connector.

This should force the MSC connection. If you see Sansa Fuze in Windows Explorer, right-click on it and Format to FAT32.

And while you are connected, send over the latest firmware.

Your Fuze is either v1 or v2 hardware. If you know which one, download the correct version. If not download both.

Download v1 from here:

Download v2 from here:

UNZIP the file. You should see FuzeA.bin for v1, a differen .bin file for v2 (I have a v1).

Drag over the .bin file to the driveletter of Sansa Fuze. Disconnect and the firmware should install. If you have a firmware problem–and it certainly sounds like you do–this ought to fix it.

The Sansa’s processor handles both the USB connection and normal operation. Sometimes, the device can simply freeze , making operation and connection to the PC impossible.

The solution to this issue is to perforn a soft reset  of the device first. Slide the power switch to the ON position and hold it in this position for 30 seconds to reset the device. Release the switch, then try powering up as usual. 

You should then be able to connect the device to your PC for access as well.  If the device freezes again when first trying to power up, perform the reset again. There may be a file corruption that is freezing the player. After resetting, try the manual MSC connection method described (slide the switch to the lower “lock” position, hold the << button while connecting the USB cable). Once connected manually, you can check the device for errors using the PC,using the chkdsk  utility,or by right clicking on the Sansa, select Properties, then the Tools tab, then select Check Volume For Errors.