Sansa fuze + weird problems


I just bought the player last week (16gb model), I use sandisk 32gb card with it, and it’s updated with latest firmware.

I had some issues when the player froze when loading card, which I fixed by changing the tags with mp3tags.

Now I have this problem: the player freeze (black screen) when playing some songs (sound stop also). I remove the card, and the player works again. I put the card back, it loads, put the same song, which is played fine. But then it freezes for another song.

The songs: mp3 format, id3v2.3 checked with mp3 tags. I don’t think it’s a file problem since it’s never the same song that freezes, and I can play the song fine after taking off and putting back the card. It just freezes for another song after. Also, it freezes when playing the song, not when changing from one song to another.

I personnaly think that this is a malfunction which can be fixed by sending the player back and getting another one. I just post here to make sure I try everything before ^^

Thank you for your help.

Edit: I tried to format the card, I put the files back, and the random freeze problem still occured.

Edit2: something new, now the player reboot by itself after freezing for 30s to 1min. Weirder and weirder.

Edit3: I put some of the files that randomly froze the sansa from the card to the internal memory, and there was no freeze. I formated the card, put the files back again, and same random freeze. It’s a class4 sandisk 32gb card.

Edit4: I checked on internet and so far I think the card is genuine, not fake

I’ve had this problem many times. Quite annoying, isn’t it?

How are you formatting this card? If your computer has a card reader, I might formatting the card with that  And using SD Formatter software. Or, if you have Windows XP or higher, and have installed Windows Media Player 10 or higher, you could format the card through the player in MTP mode. Or, as a third option, you can format the card through the player’s settings menu (Settings > Format > External uSD Card).

Also, perhaps you could solve many of your problems by connecting your player in MSC mode, and delete any file off the root directory that ends in the extension “.dat”. Your player will then take some time rebuilding these files, but once it does, you might find it to be more reliable.

If all of the above fails (or you just find it annoying that you have to go through all this), you could also try installing Rockbox. Rockbox is a third-party firmware which, in my experience, works much more reliably than the Sandisk Firmware. See HERE for instructions on how to install it.

Thank you for your help.

I tried to format using SD formater but it didn’t change a thing.

I put rockbox, and now the incriminated files are played, but the sansa interface lags now, it’s really slow and input commands are like 2 or 3 sec late, and the sound jump from time to time, like 1/2 sec each time.  It’s an improvment, sure, but it’s still not acceptable.

I must say that it’s the first time I meet this kind of problem, I don’t really know what to do.

Edit: ok, something new. I reverted to the Sansa original firmware, latest one. I still got this random freeze problem in some folders. I usually use the folder browsing from the “music” menu, and this time I tried playing the songs from the “card” menu, and so far no freeze. Unfortunatly, this “card” menu doesn’t feature a folder browsing, but at least I can play the songs.

It would be good to have someone from sandisk see this, it must be a firmware issue.

Edit2: ok, finally it freezes also when playing from the “card” menu. Out of ideas here!

When I don’t remove the card and let the freeze like that, it sometimes reboot, and it can also look like this:

The sound stops, but I can still navigate the player. Then in the folder browsing menu, the internal and sd memory are marked “empty”. And in the other browsing menus, all the song (internal and sd) are marked “unknown”. I remove the card, put it back, and the files are displayed normally, until the next freeze.

To be frank, now I would like someone to tell me it’s a hardware failure, I use the warranty, get a new working one, end of the story. Do not know what else I can do.

Edit3: the contact from Sandisk told me that the device card slot is likely to be damaged, is it relevant regarding the problems I have?