Sansa Fuze not syncing properly. :(

Hi, I have a sansa fuze 8gb. Recently I brought some new music so I happily imported it all into my music manager. I’m lazy and since I like all of my music with me and didn’t want to faff around. Formatted the fuze, inserted a 32gb SD card and set sync to copy my entire library to it. The sync says completed successfully, however when I disconnect my fuze and scroll through to check everything’s there I’m very disappointed. I have 2272 files, there are only 525 on the player.

After trying at least 5 different music managers, all with the same result. I went into my SD card via my computer. All my album folders are there but the majority are empty. I have checked that the files are actually in my music library, they are, just not copied for some reason.

If I try and copy to the fuze internal memory than everything is fine, until I get an error message that there isn’t enough space. I have 9.2GB of music currently in library and only 7. Something internal memory.

Please help. I don’t think it can be the SD card as some are copied and my computer shows that there is plenty of space left.


Try taking the music manager and sync functions out of the process. You can manage the music all you want on your computer, and maybe you want to make playlists or something with the music manager, but for simple transferring you don’t need any extra software that can mess things up.

Change Settings/System Settings/USB Mode to MSC.

Connect the Fuze to your computer, which will see it as two disc drives.

Go to wherever your music manager stashes your music library  and directly copy the files onto the MicroSD card (which will show up as Removable Disc on the driveletter following Sansa Fuze). See if they reach the card that way.

There is, unfortunately, a limit to the size of the Fuze database–the index of the songs that lets you find them on the Fuze.

People seem to start having database trouble after 5000 songs. It depends on the length of the filenames and the amount of information in the tags–that is, if your filenames are 01–The Beatles–Sgt. Pepper’s Lonely Hearts Club Band–Sgt. Pepper’s Lonely Hearts Club Band.mp3  or 01-SPLHCB.mp3. It adds up. When the Fuze was introduced, giant microSDHC cards weren’t around yet.

If you do hit the database limit because you have so many songs, your workaround is to use Rockbox,, the alternative firmware for Fuze.

But  simple drag-and-drop should put the music in the folders on the card. 

1 Like

Thanks for the suggestions. Unfortunately tried them and it didn’t work, in fact even more folders were blank! Could rockbox be a solution or do I have a faulty player/card? 

You can check the card with h2testw.

Or put the card in a reader,  a camera, maybe a phone, anything with the basic MSC connection, and drag and drop the files onto the card. 

Are you looking via your computer and finding empty folders? Or not seeing the folders at all?

The USB mode controls what the computer can see. (The Fuze doesn’t care how the music got there.) If you sent stuff over in MTP mode, it’s invisible to your computer in MSC mode, and vice versa. I have no idea what your many music managers were using.

Let’s try to simplify the troubleshooting. Otherwise we are dealing with who knows what debris from your many syncs.

Try h2testw to make sure the card’s not bad. Then, if it’s good, format it and load everything you want on there via  MSC mode.  Then search with your computer to see if everything is actually on the card.

1 Like

Hey, I was wrong there is something wrong with the card. :frowning: Info below:

Warning: Only 31188 of 31189 MByte tested.
The media is likely to be defective.
1.7 GByte OK (3674048 sectors)
28.7 GByte DATA LOST (60198976 sectors)
Details:32 KByte overwritten (64 sectors)
0 KByte slightly changed (< 8 bit/sector, 0 sectors)
28.7 GByte corrupted (60198912 sectors)
32 KByte aliased memory (64 sectors)
First error at offset: 0x00000000701f8000
Expected: 0x00000000701f8000
Found: 0x000000079d3f0000
H2testw version 1.3
Writing speed: 3.18 MByte/s
Reading speed: 3.91 MByte/s
H2testw v1.4

Any idea what it means apart from it’s not working properly and is there a programme to fix.


(H2testw is a useful little tool I think I’ll be keeping it.) :slight_smile:

…I ran the chkdisk facility in windows and then formatted the device. Now it says there are no errors but when I drag and drop I still have the same problem. All the folders are there but some of them are empty and the empty folders are not showing at all on my fuze.


You may have a counterfeit card–a 2GB card disguised so your computer will initially read it as a 32GB card.  There are bad people out there.

You can Google around for card-fixer programs but if the gigabytes aren’t there they won’t help. Still, worth a try.

Can you return it to the seller? Even if you can’t, there are legit 32GB cards on Amazon and elsewhere now for only about $22 shipped. I just got one (tested with h2testw) from Everything But Stromboli, an Amazon seller, and I have also gotten good inexpensive cards from Kefers at Amazon.

1 Like

how do I tell if it is or not and ditto the same question if I buy another one? I brought it off so doubt it is counterfeit but it was a couple of years ago so sadly can’t return.

H2testw is how you can tell. It looks like you got a 2GB card tweaked to read like 32GB.

I use H2testw to test every microSD when it arrives.

Read the readme.txt file in the h2testw folder, or look at this.

If you tried CHKDSK, you should cut your losses and just get a new microSD.

And you might also get in touch with anyway and make threatening noises about lawsuits, counterfeiting, fraud, etc.if you feel like it.

1 Like

Thanks for all your help. Testing a new card as I type this. Hopefully everything will go smoothly. :slight_smile: Fingers crossed!