Files mixed up

Hi! First I’m French so my English may be poor, please excuse me for that.

I have a Sansa Fuze+ (16 GB + microsd 32 GB, firmware updated) since yesterday and I’ve got some trouble with the files I transferred. I use the MTP mode and I transfer via Windows Explorer (Vista). Everything is ok at this point. But when I look into the directories, the files look like they have been mixed up, some files have been copied into other directories, and some seem to have disappeared.

For example : I’m using this kind of arborescence : /Music/Artist/Album/Song.mp3

I transferred the following albums : /Music/Keith Jarrett/The Köln Concert and /Music/Dave Brubeck/Time Out

Everything went right but if I take a look into /Music/Dave Brubeck, there will be the album “The Köln Concert” inside instead of “Time Out”, while inside /Music/Keith Jarrett there will also be “The Köln Concert”. “Time Out” is nowhere to be found. When I look at the size of the Music folder, it says 9 GB (copied files are taken into account) while “External Storage” indicates 6 GB of used space, which is the real amount of files I transferred.

This happens in both internal and external memory.

When I run the Sansa Fuze+ every music file is there, even those who have “disappeared”, like if nothing strange ever happened.

I tried to restart my computer, I tried to restart the Fuze+, I tried with an other computer, the problem won’t solve.

Could someone tell me what I should do?

Thanks. I hope you understand what I write.

Try it in MSC mode see if they all appear weather on the card or on the internal mem.

In MSC mode everything is ok. If I get back to MTP mode the problem is still there. I don’t understand what’s wrong.

Format your Fuze+ (which will wipe out everything), switch the player to MSC mode and re-load your content. You’re going to confuze everything if you have files loaded on in both modes. You only need MTP if you are dealing with any DRM-encrypted files (like from Rhapsody, Audible, etc.).

I don’t have any file transferred via MSC, I just wanted to say that in this mode the files are in their right places. In fact I use MTP so I can create playlists (which apparently doesn’t really work in MSC), especially playlists that gather songs from both internal and external memories.

Maybe someone could tell me how to create proper playlists in MSC, that would be a great help.

I’ve had this problem as well.  It seems to only affect Folder View.  The files in Folder View seem to be sorted by date added rather than alphabetically, and some get mixed up or disappear all together.  It’s a really stupid and frustrating bug.

Also, I only ever use MSC mode, so I can confirm that has nothing to do with it.