Issue with my Fuze and Micro SD, please help :)

Hello!

To start Sansa:
*2gb
*refurb
*Firmware version: 2.03.33

And my micro sd is 4gb.

I have succesfully used in the past the same micro sd without issues. But one day decided to changed my music so I deleted the music in the MicroSD and now that I have put my music together again I tried the following things:

-Put the MicroSD into my laptop, transfered the music and then put the SD on my fuze, and didn’t work, it did said refresehing media and all that but at the end said NO SONGS.
-Put the SD into my Fuze, connected it to the laptop and try to pass the music with the following results =
 *Sync - said changes could not be saved, try again or unplug and plug again and try again (neither worked).

 *Right now I can’t remember which is MTP and which MSC, but in the one that recognizes the sansa as just folders like and extra letter of the disk? It shows all the folders, like Music, Audiobooks, etc etc etc but just recognizes the 2gb of the sansa itself and not also the 4 of the SD, so I don’t have the space.
  --In the option that recognizes sansa as an mp3 player and you get all the options like sync and browse files etc etc, as sync doesn’t work I try to go to browsing files then it shows the external usd card and the internal memory, there I have 2 issued first my external usd card was showing but as full because it said it had 0mb of capacity and also 0mb free, then I don’t know what I did or why it happened but then it started recognizing the card the whole capacity which actually shows something like 3.66gb but when I tried to transfer things there, and it said I was not allowed to make changes or add things.   The latest was that it was not letting me add anything so I format the external usd card while it was still in the sansa with the option it gave me by right clicking and that was it is showing again that it has capacity of 0mb and 0mb free.
When the SD is like that I have noticed my sansa gets slower specially if I try to access System > Info.

Any suggestions please? I really miss my sansa, I was able to use it without a problem before, I don’t know what happened.

I also have format the Sansa, soft reset, restore factory setting… and all the “simple” things without luck.
As well I format my SD outside the sansa, in FAT 32 and it my laptop it does work good and shows and let me store things etc, issue is when I put it inside sansa.

So right now my two issues are: Having my Sansa recognize the sd with the real capacity it has and also letting me add music.

Thank You So Much in Advanced !  

Musi =^.^=

UPDATE:

I did an “extensive” format to my MicroSD (unchecked the “quick format” option) in my computer, with no luck, then I decided to add ANY file to the SD and put it inside the Sansa and now Sansa IS recognizing the SD with its full capacity, took the memory out, deleted that file and insert the memory again, and Sansa keeps recognizing the SD “correctly”.   Then I connected the sansa in MTP and said I didn’t have permissions to make changes so couldn’t add a single thing.    Unplugged, changed USB mode to MSC and connected again, this time it was still recognizing sansa internal memory PLUS external (SD) opened that last one and copied my music folders/files (all mp3 and sansa haven’t created any folders on the sd or anything). Unplugged >refreshing media… Then I went to System > Info  and it was still showing internal memory as it should, SD also as it should, with the capacity it has and with only 753mb (which is correct since I put like 3gb in music) but where it shows how many songs or files of other types still says 0 songs :frowning:

Try this. Reformat the SD from the laptop to FAT 32.

Look at the music files you are trying to add. They have to be .mp3, .wma, .ogg or .flac files.

If you can’t see file extensions, you have to go to Windows Explorer (Computer or My Computer), Tools/Folder Options/View and uncheck Hide Known File Extensions. That’s XP. It might be slightly different in Vista or Win7.

The Fuze won’t play m4a, m4p or aac files from iTunes.

As long as the files are playable, drag and drop music onto the card, in whatever reader you are using, directly–not through the Fuze. Put it in the Music folder, or anywhere else except Audiobooks, Podcasts, Photos or Temp.

Put the card in the Fuze and see if it reads the music.

The Fuze only plays .mp3, .wma, .flac, .ogg and .aa files. If you were trying to copy songs from iTunes, they may be in Apple formats (.m4a, .m4p, .aac) that the Fuze won’t play.

I would retry formatting the card in the computer, copying files you know the Fuze can read (.mp3, etc) and then retrying the card in the Fuze.

Use MSC mode, the straightforward files/two drives mode. The other one, synching with Windows Media Player, is MTP, and it’s more complicated, so leave it alone for the moment.

The card slot could be not working–which means the Fuze is DOA–or the firmware could be glitching (easy fix). But first see what happens with files that you know are good: .mp3, etc. 

All my files are .mp3 and in the MSC it only shows that  I have like 1.7gb of memory (the internal one) instead of the internal + external.

I will try formatting my SD again.

And how can I now if its the firmware glitching? I recently updated it.

Thanks for replying :wink:

MSC will show two separate drives–internal (Sansa Fuze) and then Removable Disc for the microSD card. It doesn’t combine them.  And  if you were transferring to the card via MTP, it won’t show the files that were transferred that way–but it should show the card. 

It wouldn’t hurt to just do the firmware install again. Don’t use the updater. (In fact, you might as well uninstall it if it’s on your computer–updates are rare and you don’t need it phoning home every time you connect the Fuze.) 

Download from the All Regions link for your Fuze version (shown in Settings/Info), unzip it in your computer and drag fuzeA.bin over to the root directory (the driveletter) of the internal memory in MSC mode.

Does the Fuze by itself read the card now? I’m not quite sure from your previous posts. If the Fuze itself isn’t reading or writing to the the card, and you’ve established that the card itself works in other readers,  the slot might be damaged. And that’s not fixable via software.

Yes the Fuze itself is reading and recognizing the card BUT not the songs. for example it does show it has the external SD, it shows that its capacity is 4gb and that it only has like 800mb free (because I added via MSC mode around 3gb of music).  
But it still says NO SONG.   So it is recognizing the card and capacity, but not its content.

@musiek wrote:

Yes the Fuze itself is reading and recognizing the card BUT not the songs. for example it does show it has the external SD, it shows that its capacity is 4gb and that it only has like 800mb free (because I added via MSC mode around 3gb of music).  
But it still says NO SONG.   So it is recognizing the card and capacity, but not its content.

Do the .mp3 files have ID3 tags? And are they the format that your player is looking for (ID3v2.3 ISO-8859-1)?

How can I know/check if they have those tags?   and how do I know if that is the format the fuze is looking for?

TIA :smileyvery-happy:

The way the Fuze makes the lists–Album, Artist, Song–is from ID3 tags:  electronic labels in the files. Songs you buy usually have those tags already. When you rip a CD with Windows Media Player or other programs, they look for the tags online to add them.

But it gets a little complicated because there are a lot of versions of ID3. 

Depending on how your songs were tagged, the Fuze may not be able to read them.


Let’s cut to the chase: Try fixing the versions of your tags. Get MP3TAG. It’s free. 

Install mp3tag.  When you install, let it add itself to context menus (an option while installing).

Open mp3tag and in Tools/Options/Tags/Mpeg make the Write option ID3v2.3 ISO-8859-1.

Now go to one of your “missing” albums, right-click on the folder, and open it with mp3tag (should be in the list). It will show all the tag information on your songs, including the version.

What I do with every album, before I send it to the Fuze, is to make sure the songs are in order top to bottom (click on the the Track number column heading if they are listed differently). Then highlight them all, go to Tools/Options/Auto-Numbering Wizard, check Leading Zeroes and run it.

This does two things: it puts track numbers as 01,02, etc., which the Fuze prefers,  and since you changed the Write option, it makes the tags ID3v2.3 ISO-8859-1.  Now replace the version on your Fuze with your re-tagged version, and see if it shows up.


Let’s hope the tag info is there–Title, Album, Artist, etc. If it’s not, but you have good filenames, mp3tag has a nifty Convert function. It will convert Filename to Tag. So if for some reason the ID3 tags are empty but you have filenames like 01-Artist-FirstSong, mp3tag can fill the tag fields. If you put %track%-%artist%-%title% in Convert, it will give you instant ID3 tags.(see the dashes? If they were spaces in the filenames instead, you’d use spaces. Etc.) You can also fill in Artist, Album, etc. for the entire album at once, just by highlighting everything, filling in the field on the left, and Save.


And…as to the why…tag versions.

The Fuze does not read ID3v1 tags at all. And there are various versions of ID3v2. It’s a mess, and I wish they just standardized, but various ripping programs, players, computers and operating systems all do different things.

The tags the Fuze likes best are the kind Windows Media Player makes by default:   ID3v2.3 ISO-8859-1. (ISO-8859-1 just means basic Windows English-language encoding–how it shows the characters.)

It can also handle ID3v2.2 (which is what iTunes does) and sometimes ID3v2.4. (iTunes also does track numbers as 1/12, 2/12, etc., which needs the Leading Zeroes fix.)  Even in ID3v2.3, the tags might  be encoded as Unicode–UTF-8 or UTF-16–instead of ISO-8859-1.  A mess. But mp3tag fixes it, and fast.


By the way, you CAN go by folders if you prefer. Scroll down through the Music menu, past the first screen, and you’ll see Folders.

Downloaded the program and updated all the tags, still not working, it continues to recognize the SD card and capacity but keeps saying no songs. 

What I have noticed is that the first time I transfered the music to the sd when it was “refreshing media” it took sooooooo long, but now doesn’t matter if I add 1 or 19 folders it takes the same which is relatively quick.

Shouldn’t the fuze create like subfolders on my SD similars to the ones it has on the internal memory when you see it in MSC?

Thanks :slight_smile:

It doesn’t create folders on the microSD. That’s just more storage.

This No Songs thing is really bizarre. When you look at the tags in mp3tag,  are the fields (Artist, Album, Song, Genre) filled in or blank? Is the version ID3v2.3 ?  Also, are you  transferring in MSC mode?

Bizzare indeed. I already bookmarked this topic to see how this will be resolved:smileyvery-happy:

By the way OP, when you load the same songs to internal memory sansa are they showing up?

Do you happen to have another MicroSD card that you can test with your fuze?

sorry for the delay replying but has been a crazy week…

Yes I am tranfering in MSC mode.

And yes it shows the title and that… about the version not so sure, I’ll check and post.

Yes in internal memory are showing, well I just tried uploading a couple but yes they do show.

I don’t have another MicroSD card, but I will see if I can borrow one :slight_smile:

I’m having a similar problem.  I just got a Fuze from woot.com.  It’s probably a refurb, (though there is no indication of that on the device).  It is using latest firmware 2.03.33A.

Connects fine to my PC (Win XP), in both MTP and MSC mode, and I was able to load music, and even videos using the Sansa Media Converter utility, as well as with other 3rd party tools .  Seems to work great except for the following…

PROBLEM:  It does not seem to read the micro-SD card correctly.  When connect to the PC, the computer recognizes that a card was inserted, sort of, but isn’t able to see the card correctly.  Cliking on the drive in explorer causes a prompt to insert a card.  Or, it seems to freeze up Explorer and any other programs related to disk or USB usage.  On the Fuze itself, inserting the card causes “Refreshing your Media” to occur, but  browsing the Folders in Music shows <Empty>.  However, in the system settings, it indicates that the card has 982 MB used in the system settings, which is the correct disk usage I see if I connect the card directly to the PC in a reader.

This happens with 2 different 1GB micro-SD cards (Kingston non-SDHC), which are otherwise readable in my PC’s card reader, as well as in my Sansa E250. 

Regarding MP3 tag problems, I don’t think that’s it, because as I said the cards work and are recognized correctly when inserted in my Sansa e250.

Is this an indication of a fault card slot?  It’s strange that the card is recognized and scanned, but files don’t show up, even though the capacity is reported in the system settings.  Also when trying to access it from the computer, the presence of a drive is recognized, but it appears to the system as if a card is not inserted.

Sounds like the card slot doesn’t work: yet another bad Woot refurb. Contact them. If you search Woot here you will see that they do not have the best track record.