HELP - I tried all for the "Free 90mb" problem but nothing changed!


I have a sansa Fuze 4GB with a 4GB MicroSD.

Yeterday appeared the “not enough space for the musicDB, free 90MB”.

So I tried to:

  • Use chkdsk on both the drives = nothing changed

  • Format by from the PC both the drives = Nothing changed

  • Upgrade firmware from the Sansa software = It recognises the sansa, it seems to upgrade the firmware but when i plug again the fuze it recognise the old firmware and it ask again to upgrade.

When I plug the sansa The PC found a “##MUSIC#” drive (fuze internal memory) and another drive for the 4gb MicroSD.

I can delete anything because the “MUSIC” directory seems empty (like it’s running in the wrong mode)

Plese, can anyone help me!!!


I tried to press HOLD+LEFT when the “Free 90MB” message is on the screen (Just before the Fuze shut off) and the fuze begins to work.

 So I put the fuzeon the another USB mode and I’ve upgraded the firmware, but nothing changed.

When I Power on the Error message shows, if I Press Hold and Left i can use it but somtimes freezes again.

Any Ideas??