New Fuze, filled disk, now stuck at "Not enough space for Music DB. Please free 90M."

I see that the “Not enough space for the Music DB. Please free 90M.” message is a known problem.  I have reset it buy holding the power switch to on for > 10 sec.  I can’t do anything else.   I can’t get to any menu, so I can’t format it.  I tried the “turn off, set to hold, plug in whilc pressing << rewind” procedure, all I get is the same error on the screen and no connection over USB.  The first thing I did when I bought it was set the USB mode to MSC only.  I’ve tried plugging it into Linux, MacOS X, and Windows, with and without the “turn off, set to hold, plug in while pressing << rewind” procedure.

I’m not a happy camper.  It looks to me like the firmware is seriously flawed in that when it is connected to USB, it does not go into a “connected” state immediately, it still has the flag set to try to build a Music DB which it cannot do.

It looks like I have no choice but to return this to my local retailer as defective.  Is there anything else to try?  Will there be any bug fix for this or am I going to have to be super careful to never overfill the internal flash?



From similar threads on this forum it seems it’s more a corrupt database file than lack of space causing this.

Are you sure you are supposed to set the player on ‘hold’ when trying to get into the menu? Sounds counterintuitive to me.

The solution proposed is indeed getting into the menu and using the internal ‘format’ option.

I appreciate the time you took to respond, but I have tried both the << rewind button and the center button, both were mentioned in different threads.  I tried with and without the hold button.   I’m not trying to get to the menu – haven’t seen any option for that – I’m just trying to force it into MSC mode so I can delete files from a computer.  I am certain that the flash is full, I did a recursive copy of my mp3s until it filled the disk, then noted where it stopped and copied the rest to a microSD card.

This device seems to be sadly lacking in a dependable recovery mode.  With no access to the menu because of the error message stuck on the screen and no access to the internal flash as a MSC device because it is stuck with the error message, it’s now a small, handheld, brick.  I’m appalled that all I had to do to make it into a brick was fill the internal flash with files.

I’m not interested in an iPod any more since Apple as started getting really nasty about third party programs.  I bought a Sansa because SanDisk advertises Linux support.  I want to do business with a company that doesn’t care what OS I use.  I’ve done some awful things to iPods and they NEVER failed to go into disk mode when attached to a computer.  I think someone needs to take a serious look at every piece of code in the Fuze between power on and “become a USB disk” and make sure NOTHING can get in the way of that.  It looks like the “scan the flash for files and build a database” comes first and that, as I have found, is bad.


Just like a good sauce, the plot thickens :wink:

I took the Fuze back to Micro Center.  They exchanged it for a new one.  (That’s why I buy there… I’ve been buying there since 1984 at the original location in Lane Avenue Mall in Columbus, Ohio.)  This time, I had filled to capacity the microSD card.  I removed the last partial album to leave about 100M free on the microSD card.  Got to my car, plugged the Fuze into the car, popped in the almost full card, and it built an index and all was well. 

I just got home and connected it to my PC.  This one has a different file system on it than the first one did.  The first one had a partition table and it was primary partition 1 (/dev/sdf1 it happened to be for me) that had the file system.  This one has no partition table and the vfat filesystem is on the block device (/dev/sdf).  This is roughly equivalent to the way a floppy works… just one file system, no partitions.  Most flash devices have a primary partition 1 with the file system in it.  Oh well.  Odd and different, but it works.  The file system also has directories in it that were missing on the other one.

So… I’m not about to fill it, but I’m going to put files on the internal flash and see how it goes.