Not Enough Space for Music DB

I receive this message when I try to start up my Fuze or when I connect it to the computer (Vista, Windows 7, OS X). I have tried the soft reset option and I have tried forcing the player into MSC mode. However, when doing this the player just says to remove the hold switch to startup the player. It doesn’t seem to put it into MSC mode. 

The problem occured when I switched the player manually from MSC to MTP mode using the System Settings tab. What can I do?  Is there a hard reset option? Would draining the battery help?


You have a corrupt file.

Put the unit in MSC mode.

Connect it to a Windows computer. 

Right-click on the drive letter. 

Go to Properties.

Go to the Tools tab.

Run Error-checking–Check now…

Check Automatically fix errors.

With any luck that will kill the bad file. If it asks you to save bad chains or something like that, don’t. . 

Message Edited by Black-Rectangle on 07-11-2009 09:37 AM

The player won’t show up in My Computer so I can’t format it. I’ve tried forcing it into MSC mode but it doesn’t work.

Thanks for the help 

Are you doing the ‘force MSC’ procedure correctly?

  1. Start with the Fuze OFF
  2. Put the device in Hold (power on/off slider in the DOWN position)
  3. Press and hold the Left Button |<<
  4. Plug the 30 pin connector into the device (be sure the USB is plugged into the computer)
  5. Wait for the Fuze drive(s) to show up in Windows Explorer

I tried the procedure again and all I get it is “Not enough space for Music DB. Please free 90MB.” It just doesn’t work. What else can I try?


You shouldn’t see any message in Hold except, possibly, Key Locked System Shutdown.

Hold should prevent it from turning on until you make the connection.

Make sure you have the Hold switch slid all the way over before holding the << side of the wheel and making the connection. 

I have tried that and the player doesn’t turn on until I plug it in to the computer. Do I have a dead player?

Not necessarily dead. When you have it off and you have it on Hold it’s supposed to stay off unless you know to hold the << when you connect to the computer. And then it makes the MSC connection, and you should be able to format.

I just put the player on Hold and connected it to the computer. It turned itself on and displayed that the there isn’t enough space for the Music DB. It does the same thing when I hold down the << key. Why is my player behaving differently then the rest of yours? It is a Sansa Fuze 8GB. Thanks for your help

It doesn’t seem logical for your one unit to be working differently.

The 90MB message is a typical message with a standard solution.

Just to make sure you are doing this in the right sequence.

Push the Hold switch on so orange shows.

Plug one end of the USB cord into the (Windows) computer.

Hold the << button down and keep it down as you… 

Plug the connector into the Fuze. 

I tried the procedure again and it doesn’t work. So I tried it on my sisters Sansa Fuze 4gb and it works! Her’s shows up in MSC mode in My Computer. So I’m doing the procedure correctly and it just doesn’t work on my player :frowning: Any other suggestions to try? Can I access the BIOS to format the drive?

Sounds like you’ve exhausted all possibilities for human error and confirmed you’re doing the procedure correctly. It’s time to return it or call SanDisk for an RMA (Returned Merchandise Authorization).

The Tech Support people might have a secret tucked away that we don’t know about, but if not they can get you started on the replacment process.