Not enough space for MusicDB - Player Frozen

Hey, I’m having a problem with my Fuze. I put a lot of songs on it in MSC mode, and now when I turn it on it gives me this message:

“Not enough space for Music DB. Please free 90MB.”

Which I’ve gotten before. After that, it usually takes me to the menu, or shows up on my PC so I can either remove files or reformat the thing. But now it freezes with that message. It won’t take me to the menu, it won’t show up on my computer. I can reset it by holding the On switch for several seconds (I’ve also tried turning it on while holding << and the Home button, even when in the Hold position), but each time I turn it on, it does the same thing.

Any ideas? Any help would be great! Thanks!

  • Darin 

Edit: If I power the Fuze on, then immediately set it to hold, it flashes a message to turn it off hold, then shuts down. That’s the only other response I’ve gotten out of it so far. I’m just trying anything to trick it into letting me to a menu.

Message Edited by Darin on 07-14-2010 06:01 PM

You need to force an MSC connection with your computer so you can either run ChkDsk to check for (and fix) any corruption in 1 or more of the files or format the player. The “Not Enough Space” error message generally only means that literally if there’s not enough room for the database refresh while in MTP mode. In MSC mode you can fill’er to the brim with no problems.

With the player off, put the HOLD switch on. Now press & hold the REW |<< button while plugging the cable into the player (already connected to your computer). Have a Windows Explorer pane already open. Continue holding the |<< button until it is recognized by the computer. It will come up under Devices With Removable Storage as 2 new drives, each with their own letter designation. The 1st one will be the player’s internal memory; the 2nd will be the card slot (whether there’s a card inserted or not).

If your music files were added in MTP mode, they will not be visble while you are connected in MSC so you may need to right-click on the player’s drive and select Format. Use FAT32 and don’t pick the Quick Format option. This will format the drive and also erase anything you have put on it, so you’ll have to re-load afterwards. If this works, you’ll want to format again using the Fuze’s format option in the Settings > System Settings menu to optimize the cluster allocation. Then you can re-load your tunes. But you’ll probably still want to check them for corruption first so you don’t have to go through this again.

Thanks for the quick response. The files I added were while in MSC mode, though. I never added a file while in MTP mode.

I tried your solution on a Windows XP Laptop, and Windows simply said a USB Device was not recognized. This is an old version of XP, so the drivers are probably out of date. I’ll have to get that worked out, and then give it another try. The fact that it acknowledged a USB device was a little progress, though! Ubuntu or XP through virtual machine wouldn’t. I wish these devices had better support for Mac/Linux.

Just out of curiosity, how does (and in what format/filesystem) the Fuze format its internal memory?

Thanks again. I’ll post back when I get another chance to try this.

  • Darin 

Alright, updated XP. It doesn’t give the error anymore… but it just says Unkown Device, and it doesn’t show up in Explorer.

If I delete all the USB Controllers in the Device Manager, then plug it in while on Hold and pushing <<, it flashes the “Not enough space” error… but then goes to the “Refreshing your media” screen. But it shows 0 progress and seems frozen at that point.

I’ll play around a little more with XP and see if I can’t get it to recognize it. I won’t be able to do any more until tomorrow, though.

But if there are any more suggestions or ideas in the meantime, that would be great.

Thanks again!

  • Darin 

I hope you’re following Tapeworm’s exact sequence, with the Hold switch, <<. etc.

If you have it in any kind of a skin or case, take it out, just so the pins in the plug are fully connected.

If you get Unknown Device, go to Device Manager, uninstall any USB device that shows yellow triangle with exclamation point, reboot and reconnect. 

MSC works with older Windows OS than XP, and it’s using the most plain-vanilla generic USB connection, which also works in Mac and Linux. So it could be your cord, especially if you’re getting the same response from other computers. 

Edit: Another thought. If you updated your firmware, it may have switched over to Auto Detect or MTP. So you really have to force it with Hold/<<. 

Speaking of Linux, the 90 DB message can mean it’s choking on a tag it can’t read. A lot of Linux people use EasyTag, which by default puts in Unicode tags that give the Fuze indigestion. Whatever ripper/tagger you are using, go into its default settings to have it encode tags ID3v2.3 ISO-8859-1. (That ISO number is basic Windows Roman.) 

Message Edited by Black-Rectangle on 07-15-2010 06:45 AM

I’ve followed it exactly. Now using Windows XP SP3. It doesn’t matter whether I put it in Hold and hold << or not - it gives me the same message both ways:

“One of the USB devices attached to this computer has malfunctioned, and Windows does not recognize it. For assistance in solving this problem, click this message.”

That just brings up a box that then shows an Unknown Device… it doesn’t help at all. Then under Device Manager, it is listed as “Unkown Device”.

The only way I have been able to get it off the DB Error screen is to delete all USB Controllers in Device Manager, put it in Hold, hold <<, and plug it in. It then takes me to the Refreshing Library screen, but immediately freezes with 0% complete. Windows doesn’t acknowledge it, or course. I’ve also tried it with a second USB cord.

 Thanks again for all the help. Not really sure what to do from here…

  • Darin

Just to rule out the distant possibility that it’s Windows, try going Start/Run/sfc/scannow  .  That’s Windows System File Checker to make sure your drivers are OK.

Or it could be a bad cord, with the data pins not quite connecting. Or it could be some hardware problem within the unit.

If it’s less than a year old, you’re still under warranty. Regardless, you should call 1-866-SANDISK. They’ll ask you to do what you’ve already done, but maybe they have some other tricks too.

Message Edited by Black-Rectangle on 07-15-2010 06:52 AM