Sansa fuze doesnt work anymore

Hi everyone, I think I have a major problem here:

My sansa fuze (about a year old, original software) doesnt work anymore.

Only black screen, no reset works, no button works, doesnt connect to the computer.

I have tried everything but nothing seems to work.

I had this problem a few months ago but then it got fixed for some strange reason. I dont know what i did then.

can anyone help me with this?

Contact sandisk tech support.  You’ll get a faster response if you call instead of emailing them.  The fuze has a one year warranty.

My fuze was doing this for a few days… It turned out that the USB power cable had a kink in it. When I untied the cable and worked it back and forth to make sure all wires inside were connected, the cable began working and the unit began to charge.

It sounds like your unit is completely out of batteries. The first thing I would do to troubleshoot is find a different power cable to test it with, as a control to determine if its a battery issue, if the cable is malfunctioning, etc.

How much battery power did you have left when you were using you Fuze? It there was very little, and it suddenly shut off, then do this:

Resetting the player:

  1. Slide and hold the Power switch up for approximately 20 seconds.
  2. Release the Power switch.
  3. To turn the player on, slide the Power switch up then release instantly.

Hope this helps.