Sansa Fuze 2008 and Macs

My kid was recently given a Sansa Fuze, circa 2008 model by other family.  We have a Mac (do NOT have a PC).

The Mac recognizes the player and all the folders, but shows no content in the folders. (There is a ton!)

If I try to upload a file to the player, the player doesn’t recognize the file - just the old ones that were on there before.  (It plays the old files fine.)

Ive tried to change the USB to both Auto Detect and MSC, neither has worked.

Anything else I should try?

I do not have a Sansa Fuse, but I am aware this device can connect to a PC via a MSC mode or a MTP mode.

Apparently, Mac computers will only recognize a Sansa Fuze that is switched to MSC mode.

Take a look at the instructions at this web-link to force MSC mode for your Sansa Fuse. 

OR, Maybe try this direct method:

On the Sansa, press the Menu button.
From the Main Menu, select Settings.
Select System Info > USB Mode.
If the device is set to MTP, select MSC.

Already did that.  The computer recognizes the device and the folders, but not the files.

Also the player won’t play files uploaded from the Mac.

Would a format be necessary?

Do not use any computer to format the Sansa Fuse !!!  Especially not a Mac !!!

Are you able to access a PC computer for a quick check-up?.

Then you can see if the device is recognized and if the files are available.

Maybe something in this SanDisk Forum discussion will help?