SANSA FUSE+:WORST MP3 PLAYER I HAVE EVER OWNED!!!!

I have had my Sansa Fuse+ 16 GB model for a little over a month and it has stopped working already!!! Here’s what’s happening:

-It won’t charge or be recognized via USB plug in-I’ve tried different cables, ports and computers

-It will turn on briefly and shut off again.

I contacted tech support several times and the only responses I am getting instruct me to do what I have already done-several times. I fail to understand why they don’t understand that my unit is obviously defective and needs to be repaired or replaced! As of 9/9/11, I have yet to receive any reply to my most recent request.

I own an older Sansa player that still works great and had really high hopes for the Fuse+. This is most likely going to be my last Sandisk mp3 player that I will buy. Both the unit and support service are the worst that I have experienced so far.

@botomzone wrote:

I contacted tech support several times and the only responses I am getting instruct me to do what I have already done-several times. I fail to understand why they don’t understand that my unit is obviously defective and needs to be repaired or replaced! As of 9/9/11, I have yet to receive any reply to my most recent request.

 

If at all possible, _ call _ SanDisk Tech Support and talk to a live person. This should help to diminish your frustration by having to wait for an e-mail response and likely get your problem solved either immediately or a warranty replacement set up for you right away. :wink:

Tapeworm,

Thank you very much for your suggestion-I didn’t think of that! I will call tech support.